hdu3410 單調棧應用
阿新 • • 發佈:2019-02-16
Passing the Message
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 872 Accepted Submission(s): 571
Problem Description What a sunny day! Let’s go picnic and have barbecue! Today, all kids in “Sun Flower” kindergarten are prepared to have an excursion. Before kicking off, teacher Liu tells them to stand in a row. Teacher Liu has an important message to announce, but she doesn’t want to tell them directly. She just wants the message to spread among the kids by one telling another. As you know, kids may not retell the message exactly the same as what they was told, so teacher Liu wants to see how many versions of message will come out at last. With the result, she can evaluate the communication skills of those kids.
Because all kids have different height, Teacher Liu set some message passing rules as below:
1.She tells the message to the tallest kid.
2.Every kid who gets the message must retell the message to his “left messenger” and “right messenger”.
3.A kid’s “left messenger” is the kid’s tallest “left follower”.
4.A kid’s “left follower” is another kid who is on his left, shorter than him, and can be seen by him. Of course, a kid may have more than one “left follower”.
5.When a kid looks left, he can only see as far as the nearest kid who is taller than him.
The definition of “right messenger” is similar to the definition of “left messenger” except all words “left” should be replaced by words “right”.
For example, suppose the height of all kids in the row is 4, 1, 6, 3, 5, 2 (in left to right order). In this situation , teacher Liu tells the message to the 3rd kid, then the 3rd kid passes the message to the 1st kid who is his “left messenger” and the 5th kid who is his “right messenger”, and then the 1st kid tells the 2nd kid as well as the 5th kid tells the 4th kid and the 6th kid.
Your task is just to figure out the message passing route.
Input The first line contains an integer T indicating the number of test cases, and then T test cases follows.
Each test case consists of two lines. The first line is an integer N (0< N <= 50000) which represents the number of kids. The second line lists the height of all kids, in left to right order. It is guaranteed that every kid’s height is unique and less than 2^31 – 1 .
Output For each test case, print “Case t:” at first ( t is the case No. starting from 1 ). Then print N lines. The ith line contains two integers which indicate the position of the ith (i starts form 1 ) kid’s “left messenger” and “right messenger”. If a kid has no “left messenger” or “right messenger”, print ‘0’ instead. (The position of the leftmost kid is 1, and the position of the rightmost kid is N)
Sample Input2 5 5 2 4 3 1 5 2 1 4 3 5
Sample OutputCase 1: 0 3 0 0 2 4 0 5 0 0 Case 2: 0 2 0 0 1 4 0 0 3 0
Source
Recommend wxl
題意:一個小孩能看到左邊比它矮,但是最高的小孩,右邊也是一樣,這意味這我們要做兩個單調站,兩個都是單調遞增棧,(從棧頂到棧底依次遞增),假如它比棧頂元素小,這證明它沒法看到比它矮的,直接入棧,輸出-1,但元素大於棧頂元素時,從棧頂元素開始出棧,直到找到比這一個元素還要大位置,即這個元素能夠看到最遠的左邊邊界(比它高),那麼在這些出棧元素中找到最大值,那麼就是這個元素能看到左邊的值;同理找右邊也是一樣做了單調遞增棧,然後是從最後一個元素開始遍歷(如果從第一個元素開始遍歷,找不到它右邊的元素,因此要從最後一個元素開始遍歷)
#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <stack>
using namespace std;
long long a[50009];
long long l[50009];
long long r[50009];
int Count=1;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int i,j,k,n,M;
stack <int >s;
while(!s.empty())
{
s.pop();
}
scanf("%d",&n);
for(i=1; i<=n; i++)
{
scanf("%lld",&a[i]);
}
a[n+1]=-1;//先維護一個單調遞增棧,即先做看左邊的棧
//與之前的題目不同
//這道題當a[i]>棧前面的元素,那麼這些元素都需要出棧
//因為後面的元素只會看最高的,前面小於a[i]的元素沒有必要存在
//找不到小於a[i]的元素,即0
//最後再將a[i]入棧
for(i=1; i<=n; i++)
{
M=-1;
while(!s.empty()&&a[s.top()]<a[i])
{
if(a[s.top()]>M)
{
M=a[s.top()];
k=s.top();//記錄下標
}
s.pop();
}
if(M==-1) l[i]=0;//沒找到一個小於它的元素
else l[i]=k;//找到小於它的元素,將它下標記錄
s.push(i);
}
while(!s.empty()) s.pop();
for(i=n; i>=1; i--)
{
M=-1;
while(!s.empty()&&a[s.top()]<a[i])//找右邊
{
if(a[s.top()]>M)
{
M=a[s.top()];
k=s.top();
}
s.pop();
}
if(M==-1) r[i]=0;
else r[i]=k;
s.push(i);
}
printf("Case %d:\n",Count++);
for(i=1; i<=n; i++)
{
printf("%lld %lld\n",l[i],r[i]);
}
}
}