1. 程式人生 > >hdu 1098 Ignatius's puzzle

hdu 1098 Ignatius's puzzle

題目地址:

題目描述:

Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5645    Accepted Submission(s): 3871


Problem Description Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".


Input The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.

Sample Input 11 100 9999
Sample Output 22 no 43

題意:

給定f(x)=5*x^13+13*x^5+k*a*x,現給出k值 ,求能使x取任意值都能使f(x)%65==0的最小a值。

題解:

數論,數學歸納法,使f(0)能整除65 然後 假設 f(x)能整除65 證明f(x+1)也能整除65,這樣就能滿足題意任意x的條件了。

f(0)=0 能整除65, f(1)=18+ka 能整除65(假設的),假設f(x)能整除65,那麼f(x+1)=f(x)+5*[C(13,1)x^12+……+C(13,13)x^0]+13*[C(5,1)x^4……+C(5,5)x^0]+ka=f(x)+5*[C(13,1)x^12+……+C(13,12)x^1]+13*[C(5,1)x^4……+C(5,4)x^1]+18+ka。(二項式展開,泰勒展開)

可以發現除了18+ka外 其他都能整除65;所以要使f(x+1)要能整除65,那麼需要18+ka要能整除65(注意:這不是個充要條件 ,而是一個必要不充分條件)

現在整個問題轉換為  使 18+ka 能整除65的最小 a值;假設k=1,而要使a值最小 那麼a最大能取到65

所以直接列舉每個樣例a到65即可。

程式碼:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
int k=0,a=0;
/*for test*/
int test()
{
	return(0);
}
/*main process*/
int MainProc()
{
	while(scanf("%d",&k)!=EOF)
	{
		for(a=0;a<=65;a++)
		{
			if((18+k*a)%65==0)
			{
				printf("%d\n",a);
				break;
			}
		}
		if(a>65)
		{
			printf("no\n");
		}
	}
	return(0);
}
int main()
{
	MainProc();
	return(0);
}