杭電ACM 1280 前m大的數
阿新 • • 發佈:2019-02-18
前m大的數
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16923 Accepted Submission(s): 5738Problem Description 還記得Gardon給小希佈置的那個作業麼?(上次比賽的1005)其實小希已經找回了原來的那張數表,現在她想確認一下她的答案是否正確,但是整個的答案是很龐大的表,小希只想讓你把答案中最大的M個數告訴她就可以了。
給定一個包含N(N<=3000)個正整數的序列,每個數不超過5000,對它們兩兩相加得到的N*(N-1)/2個和,求出其中前M大的數(M<=1000)並按從大到小的順序排列。
Input 輸入可能包含多組資料,其中每組資料包括兩行:
第一行兩個數N和M,
第二行N個數,表示該序列。
Output 對於輸入的每組資料,輸出M個數,表示結果。輸出應當按照從大到小的順序排列。
Sample Input 4 4 1 2 3 4 4 5 5 3 6 4 Sample Output 7 6 5 5 11 10 9 9 8
解題思路
#include<iostream> #include<algorithm> #include<vector> using namespace std; int main() { int n,m,x; bool flag; vector<int> vec,vec1; while(cin>>n>>m) { vec.clear(); vec1.clear(); while (n--) { cin>>x; vec.push_back(x); } sort(vec.begin(),vec.end()); flag = false; for (int i = 0; i < vec.size(); i++) { for (int j = i + 1; j < vec.size(); j++) { vec1.push_back(vec[i] + vec[j]); } } sort(vec1.begin(),vec1.end()); flag = false; for (int i = vec1.size() - 1;i > vec1.size() - 1 - m;i--) { if(!flag)flag = true; else cout<<" "; cout<<vec1[i]; } cout<<endl; } return 0; }
錯誤程式碼:
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int main()
{
int n,m,x;
bool flag;
vector<int> vec;
while(cin>>n>>m)
{
vec.clear();
while (n--)
{
cin>>x;
vec.push_back(x);
}
sort(vec.begin(),vec.end());
flag = false;
for (int i = vec.size() - 2; i >= 0; i--)
{
for (int j = vec.size() - 1; j > i; j--)
{
if(m-- > 0)
{
if(!flag)flag = true;
else cout<<" ";
cout<<vec[i] + vec[j];
}
else {i = -1; break;}
}
}
cout<<endl;
}
return 0;
}
如果輸入的數是連續的自然數,錯誤方法是成立的。