1. 程式人生 > >杭電ACM-1064 Financial Management

杭電ACM-1064 Financial Management

Financial Management

                                                                 Time Limit: 400/200 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                 Total Submission(s): 15770    Accepted Submission(s): 9255


Problem Description Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
 
Input The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 
Output The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
 
Sample Input
100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75  
Sample Output

  
   $1581.42
  
 
 

水題,為了練翻譯......沒什麼說的,求十二個月銀行卡的平均餘額,直接求就是了。別忘了加美元符號,沒有其他格式要求。

AC程式碼如下:

#include <iostream>
using namespace std;
int main()
{
      double  a ,sum ;
      sum=0.00;                        //初始化
	for(int i=0;i<12;i++)
	{
	          cin >> a;
	  	  sum+=a;
	}
	cout<<"$"<<sum/12<<endl;     //為了方便,在這裡直接除12了
    return 0 ;
}