1. 程式人生 > 實用技巧 >【區間dp】poj 2955 Brackets

【區間dp】poj 2955 Brackets

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19132 Accepted: 9850

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < imn, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6



dp[i][j]表示i-j能匹配的數量,如果i位置和j位置一樣,則為dp[i][j]=dp[i+1][j-1]+2
然後再列舉中間點 dp[i][j]=dp[i][k]+dp[k][j]


程式碼
#include<iostream>
#include<cstdio>
#include<cstring> 
using namespace std;
char c[105];
int dp[105][105];
int main()
{
    freopen("a.in","r",stdin);
    freopen("a.out","w",stdout);
    while(scanf("%s",c+1) && c[1]!='e')
    {
        memset(dp,0,sizeof(dp));
        int len=strlen(c+1);
        for(int l=1;l<=len;l++)
            for(int i=1;i+l-1<=len;i++)
            {
                int j=i+l-1;
                if((c[i]=='(' && c[j]==')') || (c[i]=='[' && c[j]==']'))
                    dp[i][j]=dp[i+1][j-1]+2;
                for(int k=i;k<=j;k++)
                    dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]);
            }
        printf("%d\n",dp[1][len]);
    }
    return 0;
}