1. 程式人生 > 其它 >D - A Simple Math Problem HDU - 5974(數論)

D - A Simple Math Problem HDU - 5974(數論)

Given two positive integers a and b,find suitable X and Y to meet the conditions:X+Y=a
Least Common Multiple (X, Y) =b
Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*104),b(1≤b≤109),and their meanings are shown in the description.Contains most of the 12W test cases.

Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of “No Solution”(without quotation).
Sample Input
6 8
798 10780
Sample Output
No Solution
308 490

如果存在x,y,則一定滿足 gcd(x,y) == gcd(a,b),再根據題目,可以列出一元二次方程組,根據解求出x,y。

看了大佬題解才想出來的,

大佬題解連結

#include <bits/stdc++.h>
using namespace std;
int f(int x) {
    int a = sqrt(x);
    if (a * a == x) return 1;
    return 0;
}
int main() {
    int a, b, c, d, x, y;
    while (cin >> a >> b) {
        c = __gcd(a, b);
        a /= c;
        b /= c;
        d = a * a - 4 * b;
        if
(d >= 0 && f(d)) { x = (a - sqrt(d)) / 2 * c; y = (a + sqrt(d)) / 2 * c; printf("%d %d\n", x, y); } else puts("No Solution"); } }