1. 程式人生 > 其它 >Repeating Decimals UVA - 202

Repeating Decimals UVA - 202

技術標籤:VJ刷題練習演算法c語言字串

 The decimal expansion of the fraction 1/33 is 0.03, where the 03 is used to indicate that the cycle 03 repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number (fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no such repeating cycles.

 Examples of decimal expansions of rational numbers and their repeating cycles are shown below. Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.
在這裡插入圖片描述

 Write a program that reads numerators and denominators of fractions and determines their repeating cycles.

 For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal length string of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thus for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0 which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).

Input

 Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integer denominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the end of input.

Output

 For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycle to the right of the decimal or 50 decimal places (whichever comes first), and the length of the entire repeating cycle.

 In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the entire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cycle begins — it will begin within the first 50 places — and place ‘…)’ after the 50th digit.

Sample Input

76 25
5 43
1 397

Sample Output

76/25 = 3.04(0)
1 = number of digits in repeating cycle
5/43 = 0.(116279069767441860465)
21 = number of digits in repeating cycle
1/397 = 0.(00251889168765743073047858942065491183879093198992...)
99 = number of digits in repeating cycle

HINT

  要解決這個題目首先要知道如何判斷迴圈結束。我們我們要一位一位小數的判斷,當然要一位一位的計算。計算方法類似於十進位制轉換,每次乘以10。要判斷結束,可以設定一個標誌陣列來預示迴圈到來,當出現相同的餘數時找到迴圈。

Accepted

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int main()
{
	int a, b;
	int flags = 0;
	while (1)
	{
		if (flags == 0)flags = 1;
		else putchar('\n');
		if (scanf("%d %d", &a, &b) == EOF)break;
		int flag[3002];
		char cycle[60];
		int len = 0;
		int num = a / b;
		int re = a % b;
		memset(flag, -1, sizeof(flag));
		memset(cycle, '\0', sizeof(cycle));
		while (flag[re]==-1)
		{
			flag[re] = len;
			if(len<=50)
				cycle[len] = num + '0';
			len++;
			num = re * 10 / b;
			re = (re * 10) % b;	
		}
		printf("%d/%d = %d.", a, b, (int)a/b);
		for (int i = 0;cycle[i]!='\0';i++)
		{	
			if (i)putchar(cycle[i]);
			if (i == flag[re])putchar('(');			
		}
		if (len >= 50)printf("...)\n");
		else printf("%d)\n",num);
		printf("   %d = number of digits in repeating cycle\n",len-flag[re]);
	}
}