Prime Ring Problem
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
思路:
dfs演算法
程式碼:
#include<iostream>
#include<cstdio>
#include <cstring>
#include<cmath>
using namespace std;
int cir[21];
int book[21]={0};
int prime(int num){
int f=1;
for(int i=2;i<=sqrt(num);i++){
if(num%i==0){
f=0;
break;
}
}
return f;
}//判別素數
void dfs(int n,int s){
int f=0;
if(s==n+1 &&prime(cir[s-1]+cir[1])==1){
for(int i=1;i<n;i++){
cout<<cir[i]<<" ";
}
cout<<cir[n]<<endl;
return;
}
for(int i=2;i<=n;i++){
f=prime(cir[s-1]+i);
if(book[i]==0&&f==1){
book[i]=1;
cir[s]=i;
dfs(n,s+1);
book[i]=0;
}
}
}
int main(void){
int n,s=0;
while(~scanf("%d",&n)){
s++;
memset(cir,0,sizeof(cir));
cir[1]=1;
if(n==1){
printf("Case %d:\n",s);
cout<<n<<endl;
cout<<endl;
}
else{
printf("Case %d:\n",s);
dfs(n,2);
cout<<endl;
}
}
return 0;
}