1. 程式人生 > 實用技巧 >動態規劃專題之線性dp

動態規劃專題之線性dp

POJ2279Mr. Young's Picture Permutations
有N個學生合影,站成左對齊的k排,每行分別有N1,N2…NK個人,第一排站最後,第k排站之前。
學生身高依次是1…N。在合影時候要求每一排從左到右遞減,每一列從後面到前也遞減,一共有多少總方案

Input

輸入
每組測試資料包含兩行。第一行給出行數k
第二行包含從後到前(n1,n2,…,nk)的行的長度,作為由單個空格分隔的十進位制整數。
問題資料以0結束。
N<=30, k<=5;

Output

輸出
輸出每組資料的方案數

Sample Input

1
30
5
1 1 1 1 1
3
3 2 1
4
5 3 3 1
5
6 5 4 3 2
2
15 15
0

Sample Output

1
1
16
4158
141892608
9694845
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 31;
typedef long long LL;
int a[N];
int main() {
    int k;
    while (scanf("%d", &k) && k) {
        for (int i = 0; i < k; i++) {
            scanf(
"%d", &a[i]); } for (int i = k; i < 5; i++) a[i] = 0; LL dp[a[0] + 1][a[1] + 1][a[2] + 1][a[3] + 1][a[4] + 1]; memset(dp, 0, sizeof(dp)); dp[0][0][0][0][0] = 1; for (int a1 = 0; a1 <= a[0]; a1++) { for (int a2 = 0; a2 <= a[1]; a2++) {
for (int a3 = 0; a3 <= a[2]; a3++) { for (int a4 = 0; a4 <= a[3]; a4++) { for (int a5 = 0; a5 <= a[4]; a5++) { if (a1 < a[0]) { dp[a1 + 1][a2][a3][a4][a5] += dp[a1][a2][a3][a4][a5]; } if (a2 < a[1] && a1 > a2) { dp[a1][a2 + 1][a3][a4][a5] += dp[a1][a2][a3][a4][a5]; } if (a3 < a[2] && a2 > a3 && a1 >= a2) { dp[a1][a2][a3 + 1][a4][a5] += dp[a1][a2][a3][a4][a5]; } if (a4 < a[3] && a3 > a4 && a1 >= a2 && a2 >= a3) { dp[a1][a2][a3][a4 + 1][a5] += dp[a1][a2][a3][a4][a5]; } if (a5 < a[4] && a4 > a5 && a1 >= a2 && a2 >= a3 && a3 >= a4) { dp[a1][a2][a3][a4][a5 + 1] += dp[a1][a2][a3][a4][a5]; } } } } } } printf("%lld\n", dp[a[0]][a[1]][a[2]][a[3]][a[4]]); } return 0; }

Acwing272 最長公共上升子序列

熊大媽的奶牛在小沐沐的薰陶下開始研究資訊題目。

小沐沐先讓奶牛研究了最長上升子序列,再讓他們研究了最長公共子序列,現在又讓他們研究最長公共上升子序列了。

小沐沐說,對於兩個數列A和B,如果它們都包含一段位置不一定連續的數,且數值是嚴格遞增的,那麼稱這一段數是兩個數列的公共上升子序列,而所有的公共上升子序列中最長的就是最長公共上升子序列了。

奶牛半懂不懂,小沐沐要你來告訴奶牛什麼是最長公共上升子序列。

不過,只要告訴奶牛它的長度就可以了。

數列A和B的長度均不超過3000。

輸入格式

第一行包含一個整數N,表示數列A,B的長度。

第二行包含N個整數,表示數列A。

第三行包含N個整數,表示數列B。

輸出格式

輸出一個整數,表示最長公共上升子序列的長度。

資料範圍

1N30001≤N≤3000,序列中的數字均不超過2311231−1

輸入樣例:

4
2 2 1 3
2 1 2 3

輸出樣例:

2
#include<bits/stdc++.h>
using namespace std;
const int N = 3e3 + 7;
int dp[N][N], a[N], b[N], n;
int main() {
    cin >> n;
    for (int i = 1; i <= n; i++) cin >> a[i];
    for (int i = 1; i <= n; i++) cin >> b[i];
    for (int i = 1; i <= n; i++) {
        int val = 0;
        for (int j = 1; j <= n; j++) {
            if (a[i] == b[j]) dp[i][j] = val + 1;
            else dp[i][j] = dp[i - 1][j];
            if (b[j] < a[i]) val = max(val, dp[i - 1][j]);
        }
    }
    int ans = 0;
    for (int i = 1; i <= n; i++) {
        for (int j = 1; j <= n; j++) {
            ans = max(ans, dp[i][j]);
        }
    }
    printf("%d\n", ans);
    return 0;
}