1. 程式人生 > 其它 >1048 Find Coins (25 分)(hash)

1048 Find Coins (25 分)(hash)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

題目大意:

給出n個正整數和一個正整數m,問n個數字中是否存在一對數字a和b(a <= b),使a+b=m成立。如果有多個,輸出a最小的那一對。

分析:

建立陣列a儲存每個數字出現的次數,然後判斷輸出

原文連結:https://blog.csdn.net/liuchuo/article/details/52153248

hash法

666~

#include <iostream>
using namespace std;
int a[1001];
int main() {
    int n, m, temp;
    scanf("%d %d", &n, &m);
    for(int i = 0; i < n; i++) {
        scanf("%d", &temp);
        a[temp]++;
    }
    for(int i = 0; i < 1001; i++) {
        if(a[i]) {
            a[i]--;
            if(m > i && a[m-i]) {
                printf("%d %d", i, m - i);
                return 0;
            }
            a[i]++;
        }
    }
    printf("No Solution");
    return 0;
}

二分法

#include <bits/stdc++.h>

using namespace std;
vector<int> v;
int Bin(int left,int right,int key)
{
    int mid;
    while(left<=right){
        mid=(left+right)/2;
        if(v[mid]==key) return mid;
        else if(v[mid]>key) right=mid-1;
        else left=mid+1;
    }
    return -1;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("1.txt", "r", stdin);
#endif
    int n,m,i;
    scanf("%d%d",&n,&m);
    v.resize(n);
    for(int i=0; i<n; i++)
    {
        scanf("%d",&v[i]);
    }
    sort(v.begin(),v.end());
    for(i=0; i<n; i++){
        int pos=Bin(0,n-1,m-v[i]);
        if(pos!=-1&&i!=pos){
            printf("%d %d\n",v[i],v[pos]);
            break;
        }
    }
    if(i==n) printf("No Solution\n");
    return 0;
}

本文來自部落格園,作者:勇往直前的力量,轉載請註明原文連結:https://www.cnblogs.com/moonlight1999/p/15576487.html