1. 程式人生 > >hdu-1021 Fibonacci Again

hdu-1021 Fibonacci Again

scanf php strong acm each 解題思路 lines enc urn

題目鏈接;

http://acm.hdu.edu.cn/showproblem.php?pid=1021

題目類型:

斐波那契數列

題意描述:

一個斐波那契數列,如果對3取余為0,輸出yes,反之輸出no。

解題思路:

先在全局變量定一個較大值Max為1000010,然後打表,然後在寫多實例輸入,判斷輸出即可。

題目:

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60963 Accepted Submission(s): 28487



Problem Description There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input 0 1 2 3 4 5

Sample Output no no yes no no no
# include <stdio.h>
# define MAX 1000010

int a[MAX];

int main ()
{
    int i,n;
    a[0]=7%3; a[1]=11%3;
    for(i=2;i<MAX;i++)
        a[i]=(a[i-1]+a[i-2])%3;
    while(scanf("%d",&n)!=EOF)
    {
        
if(a[n]==0) printf("yes\n"); else printf("no\n"); } return 0; }

hdu-1021 Fibonacci Again