1. 程式人生 > >杭電ACM-1021 Fibonacci Again

杭電ACM-1021 Fibonacci Again

                                         Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 75703    Accepted Submission(s): 34365


 

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0

1

2

3

4

5

 

Sample Output

no

no

yes

no

no

no

 

斐波那契數列擴充套件,還是一個水題,題不難,關鍵在於10^6會溢位,long long 也過不了。

題目要求判斷F [ i ]  %  3 是否為 0,數列已給出 

F(0) = 7

F(1) = 11

F(n) = F(n-1) + F(n-2)   (n>=2)

既然數字太多過不了,那麼我們考慮找規律,這裡有一個規律是:

兩個數的餘數之和的餘數等於兩個數和的餘數

即:( f [ i-1 ]%3+f [ i-2 ]%3 )%3 = f [ i ] %3

AC程式碼奉上:

//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
long long int f[1000001];
void fun()    
{
	int i;
	f[0] = 7;f[1] = 11;
	f[0] % = 3;f[1] % = 3;
	for(i = 2;i <= 1000000;i++)
	{
		f[i] = f[i-1] + f[i-2];
		f[i] % = 3;
	}
}
int main()
{
	int n;
	int a,b;
	fun();
	while(cin>>n)
	{
		if(f[n] == 0)
		{
			cout<<"yes"<<endl;
		}
		else
		cout<<"no"<<endl;
	}
	return 0;
}