HDU 4004 二分
阿新 • • 發佈:2017-07-02
online cep gree ron hdu fall was mem 二分
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog‘s longest jump distance).
Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
Sample Input
6 1 2
2
25 3 3
11
2
18
#include<bits/stdc++.h>
using namespace std;
int a[500005]={0},L,M,maxn,N;
int solve(int k)
{
if(maxn>k) return 0;
int s=1,x=0,i,j;
for(i=1;i<=N;++i)
if(a[i]-a[x]<=k&&a[i+1]-a[x]>k) {x=i;s++;}
return s<=M;
}
int main()
{
int i,j,k;
while(cin>>L>>N>>M){maxn=0;
for(i=1;i<=N;++i) {
scanf("%d",&a[i]);
}a[N+1]=L;
sort(a+1,a+1+N); //由於輸入時的無序所以要排序
for(i=1;i<=N+1;++i) maxn=max(maxn,a[i]-a[i-1]); //第一次在輸入時做的這一步導致整個的失敗哎,以後要註意!
int l=0,r=L,mid;
while(l<r){
mid=l+(r-l)/2;
if(solve(mid)){
r=mid;
}
else{
l=mid+1;
}
}
cout<<l<<endl;
}
return 0;
}
The Frog‘s Games
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 7307 Accepted Submission(s): 3492
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog‘s longest jump distance).
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
Output For each case, output a integer standing for the frog‘s ability at least they should have.
Sample Output 4 11
Source The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest 久違的慘案,錯誤tm竟然是因為沒排序就去找最大差值只能怪自己傻逼了,很水的一個二分調到結束= =
#include<bits/stdc++.h>
using namespace std;
int a[500005]={0},L,M,maxn,N;
int solve(int k)
{
if(maxn>k) return 0;
int s=1,x=0,i,j;
for(i=1;i<=N;++i)
if(a[i]-a[x]<=k&&a[i+1]-a[x]>k) {x=i;s++;}
return s<=M;
}
int main()
{
int i,j,k;
while(cin>>L>>N>>M){maxn=0;
for(i=1;i<=N;++i) {
scanf("%d",&a[i]);
}a[N+1]=L;
sort(a+1,a+1+N); //由於輸入時的無序所以要排序
for(i=1;i<=N+1;++i) maxn=max(maxn,a[i]-a[i-1]);
int l=0,r=L,mid;
while(l<r){
mid=l+(r-l)/2;
if(solve(mid)){
r=mid;
}
else{
l=mid+1;
}
}
cout<<l<<endl;
}
return 0;
}
HDU 4004 二分