1. 程式人生 > >ZCMU Problem A: Good Joke!

ZCMU Problem A: Good Joke!

his mda tin discuss pid ble weak cpp std

Problem A: Good Joke!

Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 25 Solved: 16
[Submit][Status][Web Board]

Description

Vadim and Roman like discussing challenging problems with each other. One day Vadim told his friend following problem:

Given N points on a plane. Each point p is defined by it‘s two integer coordinates — px

and py. The distance between points a and b is min(|ax - bx|, |ay - by|). You should choose a starting point and make a route visiting every point exactly once, i.e. if we write down numbers of points in order you visit them we should obtain a permutation. Of course, overall distance walked should be as small as possible. The number of points may be up to 40
.

"40? Maybe 20? Are you kidding?" – asked Roman. "No, it‘s not a joke" – replied Vadim. So Roman had nothing to do, but try to solve this problem. Since Roman is really weak in problem solving and you are the only friend, except Vadim, with whom Roman can discuss challenging tasks, he has nobody else to ask for help, but you!

Input

The first line of the input contains an integer T denoting the number of test cases. The description of T test cases follows.The first line of each test case contains a single integer N denoting the number of points on a plane. The following N lines contain two space-separated integers each — coordinates of points.

Constraints

  • 1T10
  • 1N40
  • 0absolute value of each coordinate1000
  • 1 ≤ sum over all N in a single test file ≤ 120

Output

Output the answer for every test case in a separate line. The answer for every test case is a permutation of length N. In case there are several solutions that lead to minimal distance walked, you should choose the lexicographically smallest one. Let P denote such permutation. To make output smaller, you should output H(P). H(P) = P1 xor P2 xor ... xor PN. Have a look at the example and it‘s explanation for better understanding.

Sample Input

2 2 1 2 0 0 3 3 3 0 0 0 3

Sample Output

3 0

HINT

天坑。

#include<stdio.h>
main()
{
    int t,n; scanf("%d",&t);
    while(t--)
    {
        int ans=0,i;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            ans^=i;
        }
        printf("%d\n",ans);
    }
return 0;
}

  

ZCMU Problem A: Good Joke!