1. 程式人生 > >HDU 2032 楊輝三角

HDU 2032 楊輝三角

long tracking output hit div 詳細 表示 小s auto

楊輝三角


Problem Description 還記得中學時候學過的楊輝三角嗎?詳細的定義這裏不再描寫敘述。你能夠參考下面的圖形:
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1

Input 輸入數據包括多個測試實例。每一個測試實例的輸入僅僅包括一個正整數n(1<=n<=30),表示將要輸出的楊輝三角的層數。


Output 相應於每個輸入,請輸出相應層數的楊輝三角,每一層的整數之間用一個空格隔開。每個楊輝三角後面加一個空行。
Sample Input

2 3

Sample Output
1
1 1

1
1 1
1 2 1
#include<stdio.h>
long YH(int n,int m)
{
	long i = 1,j = 1,s1 = 1,s2 = 1;
	if(m == 1)
		return 1;
	else
	{
		m --;
		n --;
		for(j = 1;j <= m;j ++)
		{
			s1 = s1 * (n --);
			s2 *= j;
			if(s1%s2 == 0)        //盡可能盡早的減小s1,s2,否則後期會溢出
			{
				s1 /= s2;
				s2 = 1;
			}
		}
		return s1/s2;
	}
}
int main(void)
{
	long int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i,j;
		for(i = 1;i <= n;i ++)
		{
			for(j = 1;j <= i;j ++)
			{
				if(j == 1)
					printf("%ld",YH(i,j));
				else
					printf(" %ld",YH(i,j));
			}
			printf("\n");
		}
		printf("\n");
	}
	return 0;
}


HDU 2032 楊輝三角