1. 程式人生 > >poj1734 Sightseeing trip

poj1734 Sightseeing trip

att del i++ 結果 mes 提示 any efi mit

Sightseeing trip
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6919 Accepted: 2646 Special Judge

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string ‘No solution.‘ in case there isn‘t any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2

Source

CEOI 1999 分析:經典的最小環問題,當然是用經典的算法:floyd解決啦! 一個最小環肯定是由兩個點之間的最短路和次短路連接而成,如果我們求出了最短路再一條一條地刪邊求次短路,復雜度會很高,而且不止要求一對點,所以換個角度,我們考慮點k在不在最短路上。 假設k不在最短路上,那麽處理出d[i][j],再求出經過k的路,a[i][k] + a[k][j],這3個數加起來就構成了一個環,這樣就把刪邊操作改成了每次我們“添加”點時分不經過k的最短路和經過k的路考慮,這樣一定會得到一條最短路和次短路的組合,至於如何控制到底經不經過k和怎麽求最短路,當然是用到floyd算法。n <= 100,這就是很明顯的提示,而且要求任意兩點之間的最短路,還要控制到底經不經過k,這就是floyd算法的原理啊,每次我們先把沒有更新k的結果算出來,然後再更新k. 至於怎麽記錄路徑,類似於spfa的方法,每次記錄到達當前點的前驅,不斷向前更新就好了.
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<cmath>
#include<map>

using namespace std;

const int inf = 0x7ffffff;

int n, m, a[110][110], d[110][110],pre[110][110],ans = inf,tot,print[110];

void floyd()
{
    for (int k = 1; k <= n; k++)
    {
        for (int i = 1; i < k; i++)
            for (int j = i + 1; j < k; j++)
            {
            if (d[i][j] + a[i][k] + a[k][j] < ans)
            {
                ans = d[i][j] + a[i][k] + a[k][j];
                tot = 0;
                int t = j;
                while (t != i)
                {
                    print[++tot] = t;
                    t = pre[i][t];
                }
                print[++tot] = i;
                print[++tot] = k;
            }
            }
        for (int i = 1; i <= n; i++)
            for (int j = 1; j <= n; j++)
                if (d[i][j] > d[i][k] + d[k][j])
                {
            d[i][j] = d[i][k] + d[k][j];
            pre[i][j] = pre[k][j];
                }
    }
}

int main()
{
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= n; i++)
        for (int j = 1; j <= n; j++)
        {
        a[i][j] = a[j][i] = d[i][j] = d[j][i] = inf;
        pre[i][j] = i;   //記錄了i到j的最短路中j的前驅
        }
    for (int i = 1; i <= m; i++)
    {
        int u, v, w;
        scanf("%d%d%d", &u, &v, &w);
        a[u][v] = a[v][u] = d[u][v] = d[v][u] = min(w,a[u][v]);
    }
    floyd();
    if (ans == inf)
        printf("No solution.\n");
    else
    {
        printf("%d", print[1]);
        for (int i = 2; i <= tot; i++)
            printf(" %d", print[i]);
        printf("\n");
    }

    return 0;
}

poj1734 Sightseeing trip