1. 程式人生 > >POJ-2932 Coneology[平面掃描]

POJ-2932 Coneology[平面掃描]

different quit lin argv ima ack having mes side

Coneology

Time Limit: 5000MS

Description

A student named Round Square loved to play with cones. He would arrange cones with different base radii arbitrarily on the floor and would admire the intrinsic beauty of the arrangement. The student even began theorizing about how some cones dominate other cones: a cone A

dominates another cone B when cone B is completely within the cone A. Furthermore, he noted that there are some cones that not only dominate others, but are themselves dominated, thus creating complex domination relations. After studying the intricate relations of the cones in more depth, the student reached an important conclusion: there exist some cones, all-powerful cones
, that have unique properties: an all-powerful cone is not dominated by any other cone. The student became so impressed by the mightiness of the all-powerful cones that he decided to worship these all-powerful cones.

Unfortunately, after having arranged a huge number of cones and having worked hard on developing this grandiose cone theory, the student become quite confused with all these cones, and he now fears that he might worship the wrong cones (what if there is an evil cone that tries to trick the student into worshiping it?). You need to help this student by finding the cones he should worship.

Input

The input le specifies an arrangement of the cones. There are in total N cones (1 ≤ N ≤ 40000). Cone i has radius and height equal to Ri, i = 1 … N. Each cone is hollow on the inside and has no base, so it can be placed over another cone with smaller radius. No two cones touch.

The first line of the input contains the integer N. The next N lines each contain three real numbers Ri, xi, yi separated by spaces, where (xi, yi) are the coordinates of the center of the base of cone i.

Output

The first line of the output le should contain the number of cones that the student should worship. The second line contains the indices of the cones that the student should worship in increasing order. Two consecutive numbers should be separated by a single space.

Sample Input

5
1 0 -2
3 0 3
10 0 0
1 0 1.5
10 50 50

Sample Output

2
3 5

題意:給出n個不相交的圓,求出最外層的圓,也就是不在其他圓內部的圓。

思路:

這是挑戰上平面掃描的一個例題。掃描線的思想比較好理解,就是一條直線在不斷的掃描的過程中更新信息。

對於這道題而言,直線平行於y軸從左到掃描,每次到達一個圓的最左邊,找的和這個圓最近兩個圓的y坐標,檢查這兩個圓和當前的位置。每次從最左邊開始,保證的最外面的圓是首先進入。

#include "stdio.h"
#include "math.h"
#include "vector"
#include "set"
#include "algorithm"
using namespace std;
const int maxn = 4e4 + 10;
int N;
struct Cri {
    double x, y, r;
};
Cri c[maxn];
bool inside(int i, int j) {
    double dx = c[i].x - c[j].x, dy = c[i].y - c[j].y;
    return dx*dx+dy*dy <= c[j].r*c[j].r;
}
vector<int> res;
vector<pair<double, int>> events;
set<pair<double, int>> outs;
int main(int argc, char const *argv[])
{
    scanf("%d", &N);
    for (int i = 0; i < N; i++) {
        scanf("%lf %lf %lf", &c[i].r, &c[i].x, &c[i].y);
        events.push_back(make_pair(c[i].x - c[i].r, i));
        events.push_back(make_pair(c[i].x + c[i].r, i + N));
    }
    sort(events.begin(),events.end());
    for (int i = 0; i < events.size(); i++) {    
        int id = events[i].second%N;
        if (events[i].second < N) {
            set<pair<double, int>>::iterator it = outs.lower_bound(make_pair(c[id].y, id));
            if (it != outs.end() && inside(id, it->second)) continue;
            if (it != outs.begin() && inside(id, (--it)->second)) continue;
            res.push_back(id);
            outs.insert(make_pair(c[id].y, id));
         }
         else outs.erase(make_pair(c[id].y, id));
    }
    sort(res.begin(), res.end());
    printf("%d\n", res.size());
    for (int i = 0; i < res.size(); i++) {
        printf("%d%c", res[i]+1, i+1==res.size()? \n: );
    }
    return 0;
}

POJ-2932 Coneology[平面掃描]