1. 程式人生 > >HDU 1495 非常可樂 (BFS)

HDU 1495 非常可樂 (BFS)

return sin 相互 目標 ace down ont long read

大家一定覺的運動以後喝可樂是一件很愜意的事情,但是seeyou卻不這麽認為。因為每次當seeyou買了可樂以後,阿牛就要求和seeyou一起分享這一瓶可樂,而且一定要喝的和seeyou一樣多。但seeyou的手中只有兩個杯子,它們的容量分別是N 毫升和M 毫升 可樂的體積為S (S<101)毫升 (正好裝滿一瓶) ,它們三個之間可以相互倒可樂 (都是沒有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聰明的ACMER你們說他們能平分嗎?如果能請輸出倒可樂的最少的次數,如果不能輸出"NO"。
Input
三個整數 : S 可樂的體積 , N 和 M是兩個杯子的容量,以"0 0 0"結束。

Output
如果能平分的話請輸出最少要倒的次數,否則輸出"NO"。
Sample Input
7 4 3
4 1 3
0 0 0
Sample Output
NO
3

題意

題解

dfs不好控制到目標狀態的最少步數,所以選擇BFS,因為杯子沒有刻度,倒水只能從一個杯子倒入另一個杯子,要麽把自己倒完,要麽把另一個杯子倒滿。那麽下一步的狀態有六種(六種倒法),當某一個杯子的水量是s/2,次數為d時,如果另外兩個杯子有一個為空的時候(剩下一個肯定也是s/2),即為終點狀態。否則就需要再倒一次,答案就是d+1。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=1005;
typedef long long LL;
inline LL read()
{
    LL x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}

struct node
{
    int a,b,c,d;
    node(){}
    node(int a,int b,int c,int d):a(a),b(b),c(c),d(d){}
}q[1000005];
bool vis[105][105][105];
int l,r,s,n,m;
void pour(int a,int b,int c,int d)
{
    if(!vis[a][b][c])
    {
        vis[a][b][c]=true;
        q[r++]=node(a,b,c,d+1);
    }
}
int bfs()
{
    memset(vis,false,sizeof(vis));
    l=r=0;
    int a,b,c,d;
    q[r++]=node(s,0,0,0);
    while(l<r)
    {
        a=q[l].a,b=q[l].b,c=q[l].c,d=q[l++].d;
        if(a==s/2||b==s/2||c==s/2)
            return d+(a&&b&&c!=0);
        pour(a-m+b,m,c,d);//s->m
        pour(a-n+c,b,n,d);//s->n
        pour(a+b,0,c,d);//m->s
        pour(a+c,b,0,d);//n->s
        if(b>n-c)//m->n 判斷能不能把m杯中的水全部倒進n中
            pour(a,b-n+c,n,d);
        else
            pour(a,0,c+b,d);
        if(c>m-b)//n->m 同理
            pour(a,m,c-m+b,d);
        else
            pour(a,b+c,0,d);
    }
    return 0;
}
int main()
{
    while(cin>>s>>n>>m,s||n||m)
    {
        if(s%2)//奇數肯定不能平分
        {
            cout<<"NO"<<endl;
            continue;
        }
        int ans=bfs();
        if(!ans)
            cout<<"NO"<<endl;
        else
            cout<<ans<<endl;
    }
    return 0;
}

HDU 1495 非常可樂 (BFS)