poj1426 Find The Multiple (DFS)
阿新 • • 發佈:2018-08-20
targe rep org define decimal positive ostream accept cin 題目:
Find The Multiple
Time Limit: 1000MS | Memory Limit: 10000K | |||
Total Submissions: 41845 | Accepted: 17564 | Special Judge |
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.Input
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.Sample Input
2 6 19 0
Sample Output
10 100100100100100100 111111111111111111
Source
Dhaka 2002 題意:找出一個最小的由1或者0組成的十進制數能整除n 題解:dfs,一開始看題目說十進制數會達到100位,其實不會,在longlong的範圍內,下次遇到這種可以直接打表找一下規律 代碼:#include<iostream>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int > PII;
const ll mod=998244353;
#define pb push_back
#define mp make_pair
#define all(x) (x).begin(),(x).end()
#define fi first
#define se second
//head
#define MAX 1000
int n;
int flag;
void dfs(int cur,ll sum)
{
if(cur==19)return ;
if(flag) return ;
if(sum%n==0&&sum!=0)
{
flag=1;
cout<<sum<<endl;
return ;
}
else
dfs(cur+1,sum*10),dfs(cur+1,sum*10+1);
}
int main()
{
cin.tie(0);
cout.tie(0);
ios::sync_with_stdio(0);
while(cin>>n)
{
if(n==0)break;
flag=0;
dfs(0,1);
}
return 0;
}
poj1426 Find The Multiple (DFS)