1. 程式人生 > >E - Find The Multiple(DFS)(18.9.13)

E - Find The Multiple(DFS)(18.9.13)

E - Find The Multiple

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

題意:給出一個數n,然後求得一個數字k,數字滿足:能被n整除,每一位只有0,1。這樣的數字k會有很多個,然以輸出一個就可以。

思路:n的最大值為200,用dfs從數字k的個位開始往高位搜尋,每一位只有0或1。找到能被n整除的時候輸出就可以了。

ps:(一開始不知道到底應該搜到多少位時可以return,後來看到網上說最多到19位就可以)

程式碼如下:

#include <iostream>
#include <string>
#include <cstring>
#include<stdio.h>
using namespace std;
int n,flas;
void dfs(int k,long long cur)//k:位數 cur:當前數字
{
    if(k==19||flas)
        return;
    if(cur%n==0)
    {
        cout<<cur<<endl;
        flas=1;
        return;
    }
    dfs(k+1,cur*10);//高位為 0
    dfs(k+1,cur*10+1);//高位為 1
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {

        if(n==0)break;
        flas=0;
        dfs(0,1);
    }
    return 0;
}