1. 程式人生 > >HDU 5115 Dire Wolf

HDU 5115 Dire Wolf

inf bits ems cond round basic align scrip 在一起

Dire Wolf

Time Limit: 5000/5000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 3882 Accepted Submission(s): 2309


Problem Description Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by bi
. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks bi
they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.

Input The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).

The second line contains N integers ai (0 ≤ ai ≤ 100000), denoting the basic attack of each dire wolf.

The third line contains N integers bi (0 ≤ bi ≤ 50000), denoting the extra attack each dire wolf can provide.

Output For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.

Sample Input 2 3 3 5 7 8 2 0 10 1 3 5 7 9 2 4 6 8 10 9 4 1 2 1 2 1 4 5 1

Sample Output Case #1: 17 Case #2: 74 Hint In the ?rst sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.

Source 2014ACM/ICPC亞洲區北京站-重現賽(感謝北師和上交) Recommend liuyiding 題意:

給你n頭狼,每頭狼可以向周圍的狼提供bi點攻擊力,自身有ai的攻擊力

問你最小花費多少,可以把所有的狼殺死

註意,如果這個狼死了,那麽他左邊和他右邊活著的狼就會挨在一起

題解:區間DP,枚舉最後死去的那匹狼即可;dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]+a[k]+b[i-1]+b[j+1]);
#include<bits/stdc++.h>
using namespace std;
#define mem(a,b) memset(a,b,sizeof a)
#define mp make_pair
#define eps 1e-8
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
typedef long long ll;
typedef unsigned long long ull; 
const int INF=0x3f3f3f3f;
const ll inf=0x3f3f3f3f3f3f3f3fll;
const int maxn=1e5+10;
int dp[205][205];
int a[205],b[205];
inline int read()
{
	int x=0,f=1;char ch=getchar();
	while(ch<‘0‘||ch>‘9‘) { if(ch==‘-‘) f=-1; ch=getchar();}
	while(ch>=‘0‘&&ch<=‘9‘) {x=x*10+ch-‘0‘; ch=getchar(); } 
	return x*f;
}
int main()
{
	int T,n,cas=1;
	scanf("%d",&T);
	while(T--)
	{
		n=read();
		for(int i = 0;i<n;i++) a[i]=read();
		for(int i = 0;i<n;i++) b[i]=read();
		for(int i = 0;i<=n;i++)
			for(int j = i;j<=n;j++)
				dp[i][j]=INF;
 
		for(int l = 0;l<=n;l++)
		   for(int i = 0;i<n-l;i++)
		   {
			   int j = i+l;
			   for(int k = i;k<=j;k++)
			      dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]+a[k]+b[i-1]+b[j+1]);
		   }
		printf("Case #%d: %d\n",cas++,dp[0][n-1]);
	}
	return 0;
}

  

HDU 5115 Dire Wolf