1. 程式人生 > >Dire Wolf HDU

Dire Wolf HDU

Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor. Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore. Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can. — Wowpedia, Your wiki guide to the World of Warcra Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive. Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by b i. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now. For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks b i they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15). As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.

Input

The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200). The second line contains N integers a i (0 ≤ a i ≤ 100000), denoting the basic attack of each dire wolf. The third line contains N integers b i (0 ≤ b i ≤ 50000), denoting the extra attack each dire wolf can provide.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.

Sample Input

2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1

Sample Output

Case #1: 17
Case #2: 74


        
 

Hint

In the first sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.
        
 題意:有一群狼 有自己的傷害和一個附加傷害buff 可以給周圍兩隻加傷害 問怎麼殺所承受的傷害最低 

    解 : dp[ i ] [ j ]代表消滅 i 到 j 區間內 所有狼所承受的最小的附屬傷害   我們先 列舉 k 代表 消滅狼的範圍  ,列舉 i 開始

那麼 j 為 i + k -1  ,在列舉 一個 s 代表最後擊殺的狼的位置

#include <bits/stdc++.h>
using namespace std;
#define ll long long
int a[220],b[220];
int dp[220][220];
int main()
{
    int t,n;
    scanf("%d",&t);
    for(int oo=1;oo<=t;oo++)
    {
        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        int ans=0; //本身傷害的和
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=1;i<=n;i++) scanf("%d",&a[i]),dp[i][i]=0,ans+=a[i];
        for(int i=1;i<=n;i++) scanf("%d",&b[i]),dp[i-1][i-1]+=b[i],dp[i+1][i+1]+=b[i];
        for(int k=2;k<=n;k++)
        {
            for(int i=1;i<=n-k+1;i++)
            {

                int j=i+k-1;
                dp[i][j]=0x3f3f3f3f;
                for(int s=i;s<=j;s++)
                {
                   dp[i][j]=min(dp[i][j],dp[i][s-1]+dp[s+1][j]+b[i-1]+b[i+k]);
                }
            }
        }
        printf("Case #%d: %d\n",oo,dp[1][n]+ans);
    }
}