poj 3140Contestants Division(樹形dp刪邊)
Description
In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?
Input
There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N
N = 0, M = 0 indicates the end of input and should not be processed by your program.
Output
For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.
Sample Input
7 6 1 1 1 1 1 1 1 1 2 2 7 3 7 4 6 6 2 5 7 0 0
Sample Output
Case 1: 1
Source
刪除某條邊,是剩下兩部分點權值差最小,輸出權值差。
思路:以其中一點為根節點,求沒點的子節點的權值和,然後根據每點子節點的權值和求刪除該點與該點父親節點的連線的兩部分的點的權值差。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 100005
#define ll long long
using namespace std;
struct point
{
int v,next;
}edge[10*maxn];
int n,m,cnt,head[maxn];
ll dp[maxn],ans;
void init()
{
memset(head,-1,sizeof(head));
memset(dp,0,sizeof(dp));
cnt=0;
}
void addedge(int u,int v)
{
edge[cnt].v=v;
edge[cnt].next=head[u];
head[u]=cnt++;
}
void dfs(int u,int p)
{
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].v;
if(v==p)
continue;
dfs(v,u);
dp[u]+=dp[v];
}
}
int main()
{int w=0;
while(scanf("%d%d",&n,&m)>0,n|m)
{
init();
w++;
for(int i=1;i<=n;i++)
scanf("%lld",&dp[i]);
int s,e;
for(int i=1;i<=m;i++)
{
scanf("%d%d",&s,&e);
addedge(s,e);
addedge(e,s);
}
dfs(1,-1);
ans=dp[1];
for(int i=2;i<=n;i++)
{
ll k=dp[1]-2*dp[i];
if(k<0)
k=-k;
ans=min(ans,k);
}
printf("Case %d: %lld\n",w,ans);
}
return 0;
}