1. 程式人生 > >杭電ACM-2104 hide handkerchief

杭電ACM-2104 hide handkerchief

hide handkerchief

                                                          Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                          Total Submission(s): 6917    Accepted Submission(s): 3110

Problem Description

The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .

Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".

Input

There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data. 

Output

For each input case, you should only the result that Haha can find the handkerchief or not.

Sample Input


  
   3 2 -1 -1
  
 
 
   
 
 
Sample Output

  
   YES
  
 
 

開始看了半天沒看懂題目,發現是N個人圍成一個圈,定義M,每隔M個人搜尋一次,類似於約瑟夫環但又不去掉盒子的搜尋,當M與N互質是必然搜到手帕。用輾轉相除法求得二者的公約數為1是成立。

AC程式碼如下:

#include <iostream>
using namespace std;
int main()
{
    int  a ,b ,r ;
while (cin >> a >> b )
{
  if(a==-1&&b==-1)  break;
  else
    while(b!=0 )
    {
        r = a%b;
        a = b;
        b = r;
    }
    if(a==1)
    {
    cout<<"YES"<<endl;
}
else
cout<<"POOR Haha"<<endl;
}
    return 0 ;
}