杭電ACM-1020 Encoding
Encoding
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 56525 Accepted Submission(s): 25233
Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:
1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.
2. If the length of the sub-string is 1, '1' should be ignored.
Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
Output
For each test case, output the encoded string in a line.
Sample Input
2
ABC
ABBCCC
Sample Output
ABC
A2B3C
水題,簡單的字串處理,題目大意:將類似於AAABBCC變成3A2B2C.
就是說把連續相同的字元變成 個數 + 字母 的形式,1個時不顯示個數。
#include<bits/stdc++.h>
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
char b[10005];
int main ()
{
int n,count,len;
cin>>n;
for(int i=0;i<n;i++)
{
cin>>b;
len=strlen(b);
for(int j=0;j<len;j++)
{
count=1;
while(b[j]==b[j+1])
{
count++;
j++;
}
if(count>1)
{
cout<<count<<b[j];
}
else
cout<<b[j];
}
cout<<endl;
}
return 0;
}
DP做廢了,練練簡單題