1. 程式人生 > >POJ3694 Network (LCA+tarjan+並查集)

POJ3694 Network (LCA+tarjan+並查集)

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A

and B ( 1≤ AB ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i
-th line of the following Q lines contains two integer A and B (1 ≤ ABN), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

題意,前兩個數給出無向圖的點和邊,後幾行給出無向圖的邊,在給出一個數,為要新增的邊數,後幾行給出要新增的邊。求每一條邊新增完後圖中的橋數。

思路:跑一遍tarjan,找出橋,用並查集記錄每一個塊。找出新增邊的最近公共祖先,當前橋的點到最近公共祖先的橋全部連線,用並查集記錄。輸出剩下的橋的數量。

#include<algorithm>
#include<string.h>
#include<stdio.h>
#include<math.h>
using namespace std;
struct path
{
    int to,nextt;
}A[400010];
int head[100010],DFN[100010],LOW[100010],pre[100010],f[100010];
int tot,indox,ans,carry,n,m,x,y;
void init()
{
    tot=indox,ans,carry=0;
    memset(head,0,sizeof(head));
    memset(DFN,-1,sizeof(DFN));
    memset(LOW,-1,sizeof(LOW));
    for(int i=1;i<=n;i++)
        f[i]=i;
    return ;
}
void add(int u,int v)
{
    ++tot;
    A[tot].to=v;
    A[tot].nextt=head[u];
    head[u]=tot;
    return ;
}
int Find(int x)
{
    if(x!=f[x]) f[x]=Find(f[x]);
    return f[x];
}
int ADT(int u,int v)
{
    int p1=Find(u),p2=Find(v);
    if(p1==p2)
        return false;
    f[p1]=p2;
    return true;
}
void tarjan(int u,int p)
{
    DFN[u]=LOW[u]=++indox;
    int tem;
    for(int i=head[u];i;i=A[i].nextt)
    {
        tem=A[i].to;
        if(tem==p) continue;
        if(DFN[tem]==-1)
        {
            pre[tem]=u;
            tarjan(tem,u);
            LOW[u]=min(LOW[u],LOW[tem]);
            if(LOW[tem]>DFN[u])
            {
                ans++;
            }
            else ADT(u,tem);
        }
        else LOW[u]=min(LOW[u],DFN[tem]);
    }
    return ;
}
void slove(int u,int v)
{
    if(DFN[v]<DFN[u]) swap(u,v);
    while(DFN[u]<DFN[v])
    {
        if(ADT(v,pre[v]))
            ans--;
        v=pre[v];
    }
    while(u!=v)
    {
        if(ADT(u,pre[u]))
            ans--;
        u=pre[u];
    }
    return ;
}
int main()
{
    while(~scanf("%d%d",&n,&m),n||m)
    {
        init();
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d",&x,&y);
            add(x,y);
            add(y,x);
        }
        f[1]=1;
        tarjan(1,1);
        scanf("%d",&m);
        printf("Case %d:\n",++carry);
        while(m--)
        {
            scanf("%d%d",&x,&y);
            slove(x,y);
            printf("%d\n",ans);
        }
    }
}