1. 程式人生 > >[ZJOI2011]道館之戰

[ZJOI2011]道館之戰

Description
口袋妖怪(又名神奇寶貝或寵物小精靈)紅/藍/綠寶石中的水系道館需要經過三個冰地才能到達館主的面前,冰地中的每一個冰塊都只能經過一次。當一個冰地上的所有冰塊都被經過之後,到下一個冰地的樓梯才會被開啟。三個冰地分別如下:

當走出第三個冰地之後,就可以與館主進行道館戰了。館主發現這個難度太小,導致經常有挑戰者能通過,為了加大難度,將道館分成了n個房間,每個房間中是兩個冰塊或障礙,表示一列冰地。任意兩個房間之間均有且僅有一條路徑相連,即這n個房間構成一個樹狀結構。每個房間分成了A和B兩個區域,每一區域都是一個薄冰塊或者障礙物。每次只能移動到相鄰房間的同一類區域(即若你現在在這個房間的A區域,那麼你只能移動到相鄰房間的A區域)或這個房間的另一區域。現在挑戰者從房間u出發,館主在房間v,那麼挑戰者只能朝接近館主所在房間的方向過去。一開始挑戰者可以在房間u的任意一個冰塊區域內。如果挑戰者踩過的冰塊數達到了最大值(即沒有一種方案踩過的冰塊數更多了),那麼當挑戰者走到最後一個冰塊上時,他會被瞬間傳送到館主面前與館主進行道館戰。自從館主修改規則後已經經過了m天,每天要麼是有一個挑戰者來進行挑戰,要麼就是館主將某個房間進行了修改。對於每個來的挑戰者,你需要計算出他若要和館主進行戰鬥需要經過的冰塊數。

Input
第一行包含兩個正整數n和m。第2行到第n行,每行包含兩個正整數x和y,表示一條連線房間x和房間y的邊。房間編號為1…n。接下來n行,每行包含兩個字元。第n + k行表示房間k的兩個區域,第一個字元為A區域,第二個字元為B區域。其中“.”(ASCII碼為46)表示是薄冰塊,“#”(ASCII碼為35)表示是障礙物。最後的m行,每行一個操作:
l C u s:將房間u裡的兩個區域修改為s。
l Q u v:詢問挑戰者在房間u,館主在房間v時,挑戰者能與館主進行挑戰需要踩的冰塊數。如果房間u的兩個區域都是障礙物,那麼輸出0。
N≤ 30 000
M ≤ 80 000

Output
包含若干行,每行一個整數。即對於輸入中的每個詢問,依次輸出一個答案。

Sample Input

5 3
1 2
2 3
2 4
1 5
.#
..
#.
.#
..
Q 5 3
C 1 ##
Q 4 5

Sample Output

6
3

動態dp板子題?其實也就是樹剖+線段樹,不過線段樹的記錄資訊就有點。。。

記錄L[0/1]表示從左下/上出發能到達的最遠距離,R[0/1]同理,並且還要記錄一個T[0/1][0/1]

轉移就列舉中間位置走上走下,然後展開的話就。。。

合併就看看程式碼吧。。。

/*program from Wolfycz*/
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
typedef unsigned int ui;
typedef unsigned long long ull;
inline char gc(){
    static char buf[1000000],*p1=buf,*p2=buf;
    return p1==p2&&(p2=(p1=buf)+fread(buf,1,1000000,stdin),p1==p2)?EOF:*p1++;
}
inline int frd(){
    int x=0,f=1; char ch=gc();
    for (;ch<'0'||ch>'9';ch=gc())   if (ch=='-')    f=-1;
    for (;ch>='0'&&ch<='9';ch=gc()) x=(x<<3)+(x<<1)+ch-'0';
    return x*f;
}
inline int read(){
    int x=0,f=1; char ch=getchar();
    for (;ch<'0'||ch>'9';ch=getchar())  if (ch=='-')    f=-1;
    for (;ch>='0'&&ch<='9';ch=getchar())    x=(x<<3)+(x<<1)+ch-'0';
    return x*f;
}
inline void print(int x){
    if (x<0)    putchar('-'),x=-x;
    if (x>9)    print(x/10);
    putchar(x%10+'0');
}
const int N=5e4,inf=1<<30;
int ID[N+10],dfn[N+10],v[N+10][2],n,m;
char str[5];
struct S1{
    #define ls (p<<1)
    #define rs (p<<1|1)
    struct node{
        int L[2],R[2],T[2][2];
        node(){
            memset(L,0,sizeof(L));
            memset(R,0,sizeof(R));
            memset(T,0,sizeof(T));
            T[0][1]=T[1][0]=-inf;
        }
        void Modify(int *V){
            if (V[0]&&V[1]) L[0]=R[0]=L[1]=R[1]=T[0][1]=T[1][0]=2,T[0][0]=T[1][1]=1;
            else    if (V[0])   L[0]=R[0]=T[0][0]=1,L[1]=R[1]=0,T[0][1]=T[1][0]=T[1][1]=-inf;
            else    if (V[1])   L[1]=R[1]=T[1][1]=1,L[0]=R[0]=0,T[0][0]=T[0][1]=T[1][0]=-inf;
            else    L[0]=L[1]=R[0]=R[1]=0,T[0][0]=T[0][1]=T[1][0]=T[1][1]=-inf;
        }
    }tree[(N<<2)+10];
    friend node operator +(const node &x,const node &y){
        node z;
        z.L[0]=max(x.L[0],max(x.T[0][0]+y.L[0],x.T[0][1]+y.L[1]));
        z.L[1]=max(x.L[1],max(x.T[1][0]+y.L[0],x.T[1][1]+y.L[1]));
        z.R[0]=max(y.R[0],max(y.T[0][0]+x.R[0],y.T[1][0]+x.R[1]));
        z.R[1]=max(y.R[1],max(y.T[0][1]+x.R[0],y.T[1][1]+x.R[1]));
        z.T[0][0]=max(-inf,max(x.T[0][0]+y.T[0][0],x.T[0][1]+y.T[1][0]));
        z.T[0][1]=max(-inf,max(x.T[0][0]+y.T[0][1],x.T[0][1]+y.T[1][1]));
        z.T[1][0]=max(-inf,max(x.T[1][0]+y.T[0][0],x.T[1][1]+y.T[1][0]));
        z.T[1][1]=max(-inf,max(x.T[1][0]+y.T[0][1],x.T[1][1]+y.T[1][1]));
        return z;
    }
    friend node operator -(const node &x){
        node y=x;
        y.L[0]=x.R[0],y.L[1]=x.R[1];
        y.R[0]=x.L[0],y.R[1]=x.L[1];
        y.T[0][0]=x.T[0][0],y.T[1][1]=x.T[1][1];
        y.T[0][1]=x.T[1][0],y.T[1][0]=x.T[0][1];
        return y;
    }
    void build(int p,int l,int r){
        if (l==r){
            tree[p].Modify(v[dfn[l]]);
            return;
        }
        int mid=(l+r)>>1;
        build(ls,l,mid),build(rs,mid+1,r);
        tree[p]=tree[ls]+tree[rs];
    }
    void Modify(int p,int l,int r,int x){
        if (l==r){
            tree[p].Modify(v[dfn[l]]);
            return;
        }
        int mid=(l+r)>>1;
        if (x<=mid) Modify(ls,l,mid,x);
        else    Modify(rs,mid+1,r,x);
        tree[p]=tree[ls]+tree[rs];
    }
    node Query(int p,int l,int r,int x,int y){
        if (x<=l&&r<=y) return tree[p];
        int mid=(l+r)>>1;
        if (y<=mid) return Query(ls,l,mid,x,y);
        if (x>mid)  return Query(rs,mid+1,r,x,y);
        return Query(ls,l,mid,x,y)+Query(rs,mid+1,r,x,y);
    }
    void Debug(int p,int l,int r){
        tree[p].print();
        if (l==r)   return;
        int mid=(l+r)>>1;
        Debug(ls,l,mid),Debug(rs,mid+1,r);
    }
    #undef ls
    #undef rs
}ST;//Segment Tree
struct S2{
    int pre[(N<<1)+10],now[N+10],child[(N<<1)+10],tot,Time;
    int fa[N+10],deep[N+10],size[N+10],top[N+10],Rem[N+10];
    void join(int x,int y){pre[++tot]=now[x],now[x]=tot,child[tot]=y;}
    void insert(int x,int y){join(x,y),join(y,x);}
    void dfs(int x){
        deep[x]=deep[fa[x]]+1,size[x]=1;
        for (int p=now[x],son=child[p];p;p=pre[p],son=child[p]){
            if (son==fa[x]) continue;
            fa[son]=x,dfs(son);
            size[x]+=size[son];
            if (size[Rem[x]]<size[son]) Rem[x]=son;
        }
    }
    void build(int x){
        if (!x) return;
        dfn[ID[x]=++Time]=x;
        top[x]=Rem[fa[x]]==x?top[fa[x]]:x;
        build(Rem[x]);
        for (int p=now[x],son=child[p];p;p=pre[p],son=child[p]){
            if (son==fa[x]||son==Rem[x])    continue;
            build(son);
        }
    }
    void work(int x,int y){
        S1::node resx,resy,res;
        while (top[x]!=top[y]){
            if (deep[top[x]]<deep[top[y]]){
                resy=ST.Query(1,1,n,ID[top[y]],ID[y])+resy;
                y=fa[top[y]];
            }else{
                resx=ST.Query(1,1,n,ID[top[x]],ID[x])+resx;
                x=fa[top[x]];
            }
        }
        if (deep[x]<deep[y])    resy=ST.Query(1,1,n,ID[x],ID[y])+resy;
        else    resx=ST.Query(1,1,n,ID[y],ID[x])+resx;
        res=-resx+resy;
        printf("%d\n",max(res.L[0],res.L[1]));
    }
}HLD;//Heavy Light Decomposition
void read(int *V){
    scanf("%s",str);
    V[0]=str[0]=='.';
    V[1]=str[1]=='.';
}
int main(){
    n=read(),m=read();
    for (int i=1;i<n;i++){
        int x=read(),y=read();
        HLD.insert(x,y);
    }
    for (int i=1;i<=n;i++)  read(v[i]);
    HLD.dfs(1),HLD.build(1),ST.build(1,1,n);
    for (int i=1;i<=m;i++){
        scanf("%s",str);
        if (str[0]=='C'){
            int x=read(); read(v[x]);
            ST.Modify(1,1,n,ID[x]);
        }
        if (str[0]=='Q'){
            int x=read(),y=read();
            HLD.work(x,y);
        }
    }
    return 0;
}