1. 程式人生 > >1018 Public Bike Management (30 分)(Dij+DFS)

1018 Public Bike Management (30 分)(Dij+DFS)

1018 Public Bike Management (30 分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect

condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

先求最短路徑最小的那個,如果最短路徑有多個,求能帶的自行車數最少的,如果還有很多條不同的路,那麼就找一個從車站帶回的自行車數目最少的。帶回的時候是不調整的(這邊奧 ,我wa了一次 有一個25分,就是因為我以為回去的時候是會調整)

結果是帶過來的是可以邊調整 帶回去是不會邊調整邊帶回去的

程式碼:

#include<bits/stdc++.h>
using namespace std;
const int inf = 0x3f3f3f3f;
int total,sta,over,road;//總共有這個數 
int much[505];
int maze[505][505];
int vis[505],dis[505];
int totalcost = 0, nowneed = inf, nowback = 0 ;
vector<int>vec,last;
struct node
{
	vector<int>vec;
	int nowneed ,nowback;
	node(){
		nowneed = inf; //想要最少送過來的 
		nowback = inf; //想要最少往回送的 
	} 
}pro,tmp;
void DFS(int beginn, int endd,int num,int more,int less)
{
	if(num > totalcost)
		return;//這個是超過就再見把 
	if(beginn == endd)
	{
		tmp.nowneed = less;
		tmp.nowback = more;
		if(pro.nowneed > tmp.nowneed)
			pro = tmp;
		else if(pro.nowneed == tmp.nowneed)
		{
			if(pro.nowback > tmp.nowback)
				pro = tmp;
		}
		return ;	
	} 
	for(int i = 1; i <= sta; i ++)
	{
		if(vis[i] == 0 && maze[beginn][i] != inf)
		{
			vis[i] = 1;
			tmp.vec.push_back(i);
			int gg = much[i] - total / 2;//當前多餘的,或者是當前缺失的。 
			int k1 = more, k2 = less;
			if(gg < 0) //表示當前缺失的
			{
				int kk = abs(gg); //表示需要撥這些過來 
				if(k1 >= kk){
					k1 = k1 - kk;
					k2 = less;
				}	
				else 
				{
					k2 = k2 + abs(k1 - abs(gg)); 
					k1 = 0;//對於的沒有了
				}
			}else if(gg > 0)
				k1 += gg;
			DFS(i, endd,num + maze[beginn][i],k1, k2);
			vis[i] = 0;	
			tmp.vec.pop_back();
		}	
	}
	return ;
}
int Dij()
{
	for(int i = 0; i <= sta; i ++)
		dis[i] = maze[0][i];  
	vis[0] = 1;//標記下哈哈
	for(int i = 0; i <= sta; i++)
	{
		int maxn = inf, u = -1;
		for(int j = 0; j <= sta; j++)	
		{
			if(vis[j] == 0 && dis[j] < maxn)
			{
				maxn = dis[j];
				u = j;
			}
		}
		if(u == -1)
			break;
		vis[u] = 1;
		for(int j = 1; j <= sta; j++ )
		{
			if(vis[j] == 0 )
			{
				if(dis[u] + maze[u][j] < dis[j])
					dis[j] = dis[u] + maze[u][j];	
			}	
		}
	} 
	return dis[over];
}
int main()
{
	scanf("%d %d %d %d",&total, &sta, &over, &road); 
	for(int i = 1; i <= sta; i ++)
		scanf("%d",& much[i]); //表示的是每個站點有多少個
	for(int i = 0; i <= sta; i ++)
	{
		for(int j = 0 ; j <= sta; j ++)
			maze[i][j] = inf;
		maze[i][i] = 0;
	}
	for(int i = 1; i <= road; i ++)
	{
		int x, y , z;
		scanf("%d %d %d",&x,&y,&z);
		maze[x][y] = maze[y][x] = z;
	} 
	totalcost = Dij(); //ok這邊就是求得對短路,然後現在開始。。。。嗯? 找路徑 
	memset(vis,0,sizeof(vis));
	vis[0] = 1; 
	tmp.vec.push_back(0);
	DFS(0, over, 0, 0, 0);
	printf("%d %d",pro.nowneed,0); 
	for(int i = 1 ; i < pro.vec.size(); i ++)
		printf("->%d",pro.vec[i]);
	printf(" %d\n",pro.nowback);
	return 0;
}