POJ-1276-Cash Machine(DP+多重揹包問題)
A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.
Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:
cash N n1 D1 n2 D2 ... nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3 4 125 6 5 3 350 633 4 500 30 6 100 1 5 0 1 735 0 0 3 10 100 10 50 10 10
Sample Output
735 630 0 0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.
In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.
In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
由題意可知,給你一個總錢數,然後給你n種兌換方式。每種兌換方式給出 x個bills可以兌換y個@。最後讓你求可用y的最大值。
是一個多重揹包問題,用模板,但是其中cost和wei是一個變數。
因為忘了更新k=1,硬懟了兩個小時。。。
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 100005
int cash,n;
int dp[maxn],cost[15],num[15];
void zeroonebag(int t)
{
for(int i = cash; i >=t; i --)
dp[i] = max(dp[i],dp[i-t]+t);
}
void completebag(int t)
{
for(int i = t;i <= cash; i ++)
dp[i] = max(dp[i],dp[i-t]+t);
}
void multibag()
{
int k = 1;
int count = 0;
for(int i = 1; i <= n; i ++)
{
if(cost[i]>cash)
continue;
if(num[i]*cost[i]>=cash)
completebag(cost[i]);
else
{
k = 1;
count = num[i];
while(k<count)
{
zeroonebag(k*cost[i]);
count -= k;
k *= 2;
}
zeroonebag(count*cost[i]);
}
}
}
int main()
{
while(~scanf("%d",&cash))
{
scanf("%d",&n);
memset(num,0,sizeof(num));
memset(cost,0,sizeof(cost));
memset(dp,0,sizeof(dp));
for(int i = 1; i <= n; i ++)
scanf("%d %d",&num[i],&cost[i]);
multibag();
printf("%d\n",dp[cash]);
}
}