1. 程式人生 > >POJ 3046 Ant Counting(dp—多重集組合數問題)

POJ 3046 Ant Counting(dp—多重集組合數問題)

 Ant Counting

Time Limit:1000MS

Memory Limit:65536K

Total Submissions:3753

Accepted:1475

Description

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants!

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants.

How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed?

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:

3 sets with 1 ant: {1} {2} {3}
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}
1 set with 5 ants: {1,1,2,2,3}

Your job is to count the number of possible sets of ants given the data above.

Input

* Line 1: 4 space-separated integers: T, A, S, and B

* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive

Output

* Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.

Sample Input

3 5 2 3
1
2
2
1
3

Sample Output

10

Hint

INPUT DETAILS:

Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made?


OUTPUT DETAILS:

5 sets of ants with two members; 5 more sets of ants with three members
題意:有n中螞蟻,第i種螞蟻有N_i個,一共有A個螞蟻。不同類別的螞蟻可以相互區分,但同種類別的螞蟻不能相互區別。從這些螞蟻中分別取出S,S+1...B個,一共有多少種取法。(解釋不清楚,請看題中的Hint)
題解:dp問題,解釋不清楚,請看《挑戰》P68~P69的多重集組合數。我也是用的那裡的模板,真心不太懂。 程式碼如下:
#include<cstdio>
#include<cstring>
#define mod 1000000
int a[1010];
int dp[1010][100010];//從前i種螞蟻中取出j個的組合總數 
int main()
{
	int t,n,s,b,i,j,x;
	while(scanf("%d%d%d%d",&t,&n,&s,&b)!=EOF)
	{
		memset(a,0,sizeof(a));
		for(i=0;i<n;++i)
		{
			scanf("%d",&x);
			a[x-1]++;//方便運算,將螞蟻編號從0計起 
		}
		for(i=0;i<=t;++i)//一個都不取的方法只有一種 
			dp[i][0]=1;
		for(i=1;i<=t;++i)
		{
			for(j=1;j<=b;++j)
			{
				if(j-1-a[i-1]>=0)//避免運算結果中出現負數 
					dp[i][j]=(dp[i][j-1]+dp[i-1][j]-dp[i-1][j-1-a[i-1]]+mod)%mod;
				else
					dp[i][j]=(dp[i][j-1]+dp[i-1][j])%mod;
			}
		}
		int ans=0;
		for(i=s;i<=b;++i)
			ans=(ans+dp[t][i])%mod;
		printf("%d\n",ans);
	}
	return 0;
}