1. 程式人生 > >HDU Diophantus of Alexandria (分解素因子)

HDU Diophantus of Alexandria (分解素因子)

Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found only recently by Andrew Wiles. 

Consider the following diophantine equation: 

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)



Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions: 

1 / 5 + 1 / 20 = 1 / 4 
1 / 6 + 1 / 12 = 1 / 4 
1 / 8 + 1 / 8 = 1 / 4



Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly? 

Input

The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9). 

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line. 

Sample Input

2
4
1260

Sample Output

Scenario #1:
3

Scenario #2:
113

就是給你個n,讓你找出有多少種 x,y滿足 1 / x + 1 / y = 1 / n

注意x>=y

見註釋:

#include<iostream>
#define Max 100005
#include<cstring>
using namespace std;
int prime[Max];
int pr[Max];
void IsPrime(){//素數打表 
	memset(pr,1,sizeof(pr));//全不是素數 
	for(int i=2;i<Max;i++) 
		for(int j=2;i*j<Max;j++) 
			pr[i*j]=0;  //標記成素數 
	int len = 0; 
	for(int i=2;i<Max;i++)  
	    if(pr[i])     
            prime[len++]=i;//用prime 陣列存下這些素數 
} 
int work(int x){ //找質因子 
	int sum=1;
	for(int i=0;prime[i]*prime[i]<=x;i++){
		if(x%prime[i]==0)//x可以被這個素數整除
		{
			int temp=0;
			while(x%prime[i]==0){//用temp記錄可以除幾次    //temp*prime[i]=x 
				temp++;
				x/=prime[i];
			}
			sum*=2*temp+1;	//因為是n*n	 
		 } 
	}
	if(x>1)
	    sum*=3;//n為質數時根據公式要乘3
	return  (sum+1)/2;//因為只要x<=y 
} 
int main(){
	IsPrime();
	int n,t;
	int count=1;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		int tmp=work(n);
		printf("Scenario #%d:\n%d\n\n",count,tmp);
		count++;
	}
	return 0;
}