1. 程式人生 > >貪心演算法——Saruman‘s Army(POJ 3069)

貪心演算法——Saruman‘s Army(POJ 3069)

題目連線

Saruman‘s Army(POJ 3069)

題目描述

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R

units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x

1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

題目限制

Time Limit: 1000MS Memory Limit: 65536K

思路

每次首先找到沒有被覆蓋的最左邊的點,然後在以此點為起點向右半徑為R的右鄰域內找到鄰域內最右邊的點,將這個點標記。然後再從這個標記的點的後面一個點開始重複上述操作。注意:首先對輸入的位置資訊排序。

程式碼

#include<iostream>
#include<algorithm>
using namespace std;

const int MAX_N = 1000;
int N,R;  //定義直線上有N個點,範圍距離為R
int X[MAX_N]; //定義直線上的位置資訊

void solve()
{
    //首先對輸入的位置資訊進行排序
    sort(X,X+N);
    
    int i=0,ans=0;   //i為計數器,ans為最終確定的點數

    while(i < N)    //每到確定點的右側鄰域最遠的點後,進行下一次迴圈
    {
        
        //首先找到直線最左邊的點
        int s = X[i++]; //s是沒有覆蓋的最左邊的點

        //根據這個點向右找到右邊鄰域最右側的點 
        while(i < N && X[i] <= s+R) i++;       //條件i<N !!

        //新標記的點
        int p = X[i-1];

        //下一步向右前進到距p的距離大於R的點
        while(i < N &&  X[i] <= p+R) i++;       //條件i<N !!

        ans++;
    }

    cout<<ans<<endl;
}

int main()
{
    while(cin>>R>>N && R != -1 && N != -1)
    {
        for(int i=0;i<N;i++)  
            cin>>X[i];
        solve();
    }
    return 0;
}

總結

貪心的目標是半徑為R的鄰域的中心,使得覆蓋點數最多(開始沒想法,依舊菜雞)