【DP+狀態壓縮】HDU
Matt has N friends. They are playing a game together. Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins. Matt wants to know the number of ways to win.
Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 10 6). In the second line, there are N integers ki (0 ≤ k i ≤ 10 6), indicating the i-th friend’s magic number.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
Sample Input
2 3 2 1 2 3 3 3 1 2 3
Sample Output
Case #1: 4 Case #2: 2
Hint
In the first sample, Matt can win by selecting: friend with number 1 and friend with number 2. The xor sum is 3. friend with number 1 and friend with number 3. The xor sum is 2. friend with number 2. The xor sum is 2. friend with number 3. The xor sum is 3. Hence, the answer is 4.
給你40個數,每個數<10^6,問你有多少種取法可以使異或和>=m
有一個bug:題目雖然告訴你數<10^6,也就是2^17,理論上來說異或和不會到2^18
但是你開到2^18就錯了,還是開到20,其實19也行
dp[i][j]=前i個數異或和為j的方法有幾個
dp[i][j]+=dp[i-1][j];//第i個數不拿 dp[i][j^val[i]]+=dp[i-1][j];//第i個數拿了
!看到40 ,看到10^6,應該有狀態壓縮的感覺,可惜當時沒想到
#include <bits/stdc++.h>
#define ll long long
using namespace std;
const int maxn=(1<<20)+5;
ll dp[45][maxn],val[45];
int main()
{
int T,cas=0;
scanf("%d",&T);
while(T--)
{
int n,m;
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++) scanf("%d",&val[i]);
memset(dp,0,sizeof(dp));
dp[1][0]=dp[1][val[1]]=1;
for(int i=2;i<=n;i++)
{
for(int j=0;j<=(1<<20);j++)
{
dp[i][j]+=dp[i-1][j];//第i個數不拿
dp[i][j^val[i]]+=dp[i-1][j];//第i個數拿了
}
}
ll sum=0;
for(int i=m;i<=(1<<20);i++)
{
sum+=dp[n][i];
}
printf("Case #%d: %lld\n",++cas,sum);
}
return 0;
}