1. 程式人生 > >2503 (map || 二分查詢)

2503 (map || 二分查詢)

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

用map做的話程式碼很簡單但耗時用了1900多ms

程式碼

#include<iostream>
#include<map>
#include<cstdio>
#include<string>
using namespace std;

int main(void)
{
	map<string,string>mp;
	char s[100],s1[100],s2[100];
	while(gets(s)&&s[0]!='\0')
	{
		sscanf(s,"%s %s",s1,s2);
		mp[s2]=s1;
	}
	while(gets(s))
	{
		if(mp.find(s)!=mp.end())
		cout<<mp[s]<<endl;
		else
		cout<<"eh"<<endl;
	}
	return 0;
}

用二分查詢的話耗時大約700ms

程式碼

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int N = 1e6 + 7;
typedef struct disi {
	char eng[12], fore[12]; // 英語及對應的外語 
}disi;

disi dis[N];

bool cmp(disi a,disi b) {  //比較函式 
	return strcmp(a.fore, b.fore) < 0;
}

 int main() {
 	
 	int k = 0;
 	while (~scanf ("%s %s", dis[k].eng, dis[k].fore)) {
 		getchar();
 		++k;
 		if (cin.peek()=='\n') break; // cin.peek() 探查輸入流的下一個字元 
 	}
 	sort(dis, dis+k, cmp); // 把外語從小到大排序 
 	char word[15];
 	while (~scanf ("%s", word)) {
 		
 		int left = 0, right = k-1, m;
 		while (left <= right) { // 二分查詢 
 			int mid = (left+right)/2;
 			m = strcmp(dis[mid].fore, word);
 			if (m < 0) {
 				left = mid + 1;
 			} else if (m > 0) {
 				right = mid - 1;
 			} else {
 				printf ("%s\n", dis[mid].eng);
 				break;
 			}
 		}
 		if (m) { //如果沒有找到 
 			puts("eh");
 		}
 		
 	}
 	
 	
 	return 0;
 }