hdu 4734 解題報告
題目:
F(x)
Time Limit: 1000/500 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9119 Accepted Submission(s): 3607
Problem Description
For a decimal number x with n digits (AnAn-1An-2 … A2A1), we define its weight as F(x) = An * 2n-1 + An-1 * 2n-2 + … + A2 * 2 + A1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 109)
Output
For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.
Sample Input
3
0 100
1 10
5 100
Sample Output
Case #1: 1
Case #2: 2
Case #3: 13
程式碼:
/* hdu-4734 */
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
const int N=1e5+5;
int digits[10];
int dp[10][N];
int a,b;
/*
引數:'
dp[pos][pre] - pre最初等於f(a),比如pos為是3,那麼執行下一個pos位時,pre就要減去3*(1<<pos),
pos - 位置
limit - 判斷是否是最大值,為真表示是最大值
*/
int f(int x)
{
if(x==0) return 0;
int ans=f(x/10);
return ans*2+(x%10);
}
int dfs(int pos,int pre, int limit)
{
if(pos==-1) return pre>=0;
if(pre<0 ) return 0;
if(!limit&&dp[pos][pre]) return dp[pos][pre];
int maxd=limit?digits[pos]:9;
int ans=0;//計數
for(int i=0;i<=maxd;i++)
{
ans+=dfs(pos-1,pre-i*(1<<pos),limit&&i==digits[pos]);
}
if(!limit)
dp[pos][pre]=ans;
return ans;
}
int solve(int n)
{
int len=0;
while(n)
{
digits[len++]=n%10;
n/=10;
}
return dfs(len-1,f(a),true);
}
int main()
{
int t;
scanf("%d",&t);
for(int i=1;i<=t;i++)
{
scanf("%d%d",&a,&b);
printf("Case #%d: %d\n",i,solve(b));
}
return 0;
}