1. 程式人生 > >HDU 3038 How Many Answers Are Wrong (帶權並查集)

HDU 3038 How Many Answers Are Wrong (帶權並查集)

Problem Description

TT and FF are ... friends. Uh... very very good friends -________-b FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers. Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose. The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence. However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed. What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers. But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N. You can assume that any sum of subsequence is fit in 32-bit integer.

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5

1 10 100

7 10 28

1 3 32

4 6 41

6 6 1

Sample Output

1

題意:給N個數,M次詢問,每次詢問給a,b,s三個數,意思是從 a 到 b 這些數的和為 s,問有幾個詢問是錯誤的。

這道題就是帶權並查集的應用,題目本身不是很難,剛開始也是一頭霧水,後來同學給我講了一下,忽然就明白了。

重點是這部分

int join(int a, int b, int s)
{
	int fa = find(a), fb = find(b);
	if (fa != fb)//如果不相等的話,就說明不能判斷他是對還是錯,就把它加到條件裡
	{
		f[fb] = fa;
		v[fb] = v[a] + s - v[b];
	}
	else//如果相等的話就說明他們的差值可以算出來,此時就只需要判斷集合差是否與給定值矛盾,矛盾就讓錯誤答案+1
	{
		if (v[b] - v[a] != s)
			ans++;
	}
	return ans;
}

這段程式碼就是這道題的核心,fa和fb為a和b的祖先,如果fa=fb,就可以將v[fb]所表示的那一段算出來,公式就是v[fb] = v[a] + s - v[b],至於這個公式怎麼來的,看下圖:

v[r2] + v[b] = v[a] + s,所以v[fb] = v[a] + s - v[b]

還有就是怎樣找祖先和更新權值

拿第一組資料來說

1 10 100         f[1-1]=f[0]=0       f [10]=10         f[f[10]]=f[10]=0

7 10 28           f[7-1]=f[6]=6       f[10]=0            f[f[10]]=f[0]=0

後面的跟上面一樣,程式碼如下

int find(int x)
{
	if (x == f[x])
		return x;
	else
	{
		int t = find(f[x]);
		v[x] += v[f[x]];//根據父節點的權值更新自己的權值
		return f[x] = t;
	}
}
//特別注意,要先更新權值再賦值,否則就錯了!!

其他的就不用說了,具體看程式碼

#include<iostream>
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define MAXN 200100
int f[MAXN], v[MAXN];
int a, b, s;
int n, m;
int ans;
int find(int x)
{
	if (x == f[x])
		return x;
	else
	{
		int t = find(f[x]);
		v[x] += v[f[x]];
		return f[x] = t;
	}
}
int join(int a, int b, int s)
{
	int fa = find(a), fb = find(b);
	if (fa != fb)
	{
		f[fb] = fa;
		v[fb] = v[a] + s - v[b];
	}
	else
	{
		if (v[b] - v[a] != s)
			ans++;
	}
	return ans;
}
int main()
{
	while (~scanf("%d%d", &n, &m))
	{
		ans = 0;
		for (int i = 0; i <= n; i++)
		{
			f[i] = i;
			v[i] = 0;
		}
		for (int i = 0; i < m; i++)
		{
			scanf("%d%d%d", &a, &b, &s);
			join(a - 1, b, s);
		}
		printf("%d\n", ans);
	}
}