1. 程式人生 > >ZOJ-2060 Fibonacci Again(斐波那契找規律,水題)

ZOJ-2060 Fibonacci Again(斐波那契找規律,水題)

ZOJ Problem Set - 2060

Fibonacci Again

Time Limit: 2 Seconds      Memory Limit: 65536 KB

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2) 

Input Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000)

Output Print the word "yes" if 3 divide evenly into F(n). Print the word "no" if not.

Sample Input 0 1 2 3 4 5

Sample Output no no yes no no no

打表找規律就好了。 

#include<iostream>
using namespace std;
 
int main()
{
    int n ;
    while(cin>>n)
    {
        if(n%4 == 2)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
 
    return 0;
}