1. 程式人生 > >ZOJ.2060 Fibonacci Again【數論-斐波那契】 2015/09/16

ZOJ.2060 Fibonacci Again【數論-斐波那契】 2015/09/16

Fibonacci Again
Time Limit: 2 Seconds      Memory Limit: 65536 KB
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2)


Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000)


Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.


Sample Input

0
1
2
3
4
5


Sample Output

no
no
yes
no
no
no

Author: Leojay

Source: ZOJ Monthly, December 2003

題意:f(0) = 7,f(1) = 11,f(n) = f(n-1) + f(n-2),判斷第n項是否能被3整除

即f(0) = 1,f(1) = 2,f(n) = (f(n-1)+f(n-2))%3,若f(n)能被3整除,則f(n)==0

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

int p[1000005];

void fun(){
    p[0] = 1;
    p[1] = 2;
    for( int i = 2 ; i <= 1000000 ; ++i )
        p[i] = ( p[i-1] + p[i-2] ) % 3;
}

int main(){
    int n;
    fun();
    while( ~scanf("%d",&n) ){
        if( !p[n] ) printf("yes\n");
        else printf("no\n");
    }
    return 0;
}