HDU 3789 奧運排序問題
阿新 • • 發佈:2018-12-16
奧運排序問題
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3989 Accepted Submission(s): 1050
Problem Description
按要求,給國家進行排名。
Input
有多組資料。 第一行給出國家數N,要求排名的國家數M,國家號從0到N-1。 第二行開始的N行給定國家或地區的奧運金牌數,獎牌數,人口數(百萬)。 接下來一行給出M個國家號。
Output
排序有4種方式: 金牌總數 獎牌總數 金牌人口比例 獎牌人口比例 對每個國家給出最佳排名排名方式 和 最終排名 格式為: 排名:排名方式 如果有相同的最終排名,則輸出排名方式最小的那種排名,對於排名方式,金牌總數 < 獎牌總數 < 金牌人口比例 < 獎牌人口比例 如果有並列排名的情況,即如果出現金牌總數為 100,90,90,80.則排名為1,2,2,4. 每組資料後加一個空行。
Sample Input
4 4 4 8 1 6 6 2 4 8 2 2 12 4 0 1 2 3 4 2 8 10 1 8 11 2 8 12 3 8 13 4 0 3
Sample Output
1:3 1:1 2:1 1:2
1:1 1:1
Source
浙大計算機研究生複試上機考試-2010年
題解
按題意模擬。注意是對給定的編號的國家進行排序。(寫了五個cmp也是…)程式碼如下:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <stack>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <utility>
#define ll long long
using namespace std ;
typedef struct{
double au_medals ;
double tot_medals ;
double population ;
double number ;
double au_population ;
double tot_population ;
int rank1 ;
int rank2 ;
int rank3 ;
int rank4 ;
int min_rank ;
int best_way ;
}meassage ;
bool cmp( meassage a , meassage b ){
return a.number < b.number ;
}
bool cmp_au( meassage a , meassage b ){
return a.au_medals > b.au_medals ;
}
bool cmp_tot( meassage a , meassage b ){
return a.tot_medals > b.tot_medals ;
}
bool cmp_au_pop( meassage a , meassage b ){
return a.au_population > b.au_population ;
}
bool cmp_tot_pop( meassage a , meassage b ){
return a.tot_population > b.tot_population ;
}
int main(){
int n , m ;
while ( cin >> n >> m ){
meassage meaa[n + 10] ;
for ( int i = 0 ; i < n ; i ++ ){
cin >> meaa[i].au_medals >> meaa[i].tot_medals >> meaa[i].population ;
meaa[i].number = i ;
meaa[i].au_population = meaa[i].au_medals / meaa[i].population ;
meaa[i].tot_population = meaa[i].tot_medals / meaa[i].population ;
}
meassage mea[n + 10] ;
for ( int i = 0 ; i < m ; i ++ ){
int number ;
cin >> number ;
mea[i] = meaa[number] ;
mea[i].number = i ;
}
sort(mea , mea + m , cmp_au) ;
for ( int i = 0 ; i < m ; i ++ ){
mea[i].rank1 = i ;
}
for ( int i = 1 ; i < m ; i ++ ){
if ( mea[i].au_medals == mea[i-1].au_medals ){
mea[i].rank1 = mea[i-1].rank1 ;
}
}
sort(mea , mea + m , cmp_tot) ;
for ( int i = 0 ; i < m ; i ++ ){
mea[i].rank2 = i ;
}
for ( int i = 1 ; i < m ; i ++ ){
if ( mea[i].tot_medals == mea[i-1].tot_medals ){
mea[i].rank2 = mea[i-1].rank2 ;
}
}
sort(mea , mea + m , cmp_au_pop) ;
for ( int i = 0 ; i < n ; i ++ ){
mea[i].rank3 = i ;
}
for ( int i = 1 ; i < m ; i ++ ){
if ( mea[i].au_population == mea[i-1].au_population ){
mea[i].rank3 = mea[i-1].rank3 ;
}
}
sort(mea , mea + m , cmp_tot_pop) ;
for ( int i = 0 ; i < m ; i ++ ){
mea[i].rank4 = i ;
}
for ( int i = 1 ; i < m ; i ++ ){
if ( mea[i].tot_population == mea[i-1].tot_population ){
mea[i].rank4 = mea[i-1].rank4 ;
}
}
sort(mea , mea + m , cmp) ;
for ( int i = 0 ; i < m ; i ++ ){
int min_rank = mea[i].rank1 ;
mea[i].best_way = 1 ;
if ( mea[i].rank2 < min_rank ){
min_rank = mea[i].rank2 ;
mea[i].best_way = 2 ;
}
if ( mea[i].rank3 < min_rank ){
min_rank = mea[i].rank3 ;
mea[i].best_way = 3 ;
}
if ( mea[i].rank4 < min_rank ){
min_rank = mea[i].rank4 ;
mea[i].best_way = 4 ;
}
printf("%d:%d\n" , min_rank + 1 , mea[i].best_way) ;
}
puts("") ;
}
return 0 ;
}