1. 程式人生 > >數論 HDU-1061 Rightmost Digit

數論 HDU-1061 Rightmost Digit

Given a positive integer N, you should output the most right digit of N^N. 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.  Each test case contains a single positive integer N(1<=N<=1,000,000,000). 

Output

For each test case, you should output the rightmost digit of N^N. 

Sample Input

2
3
4

Sample Output

7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

 題意:對於每個輸入的數字n,輸出其n的n次方最右邊的數字

# include<cstdio>
#include<cstring>
using namespace std;
long long n;

long long pow()
{
	long long result=1;
	long long x=n;
	while(x>0)
	{
		if(x%2)
			result=result*n%10;
		n=n*n%10;
		x=x/2;
	}
	return result;
}

int main()
{
	long long t;
	scanf("%lld",&t);
	while(t--)
	{
		scanf("%lld",&n);
		printf("%lld\n",pow());
	}
	return 0;
}