1. 程式人生 > >1050 String Subtraction (20 分)

1050 String Subtraction (20 分)

Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​−S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.
#include<bits/stdc++.h>
using namespace std;
int main(){
    string s1;
    string s2;
    getline(cin,s1);
    getline(cin,s2);
   // cout<<s1<<endl;
   // cout<<s2<<endl;
   // cout<<s2[1]-'0';
    bool is[256];
    memset(is,false,sizeof(is));
    //for(int i = 0 ;  i<1005;i++)
     //   cout<<is[i];
   // cout<<endl;
    for(int i = 0 ; i < s2.length(); i++)
    {
        is[s2[i]] = true;//-------------------------s2[i]可以但是s2[i]-‘0’不行??
    }
    for(int i = 0; i < s1.length(); i++)
    {
        if(is[s1[i]] == false)
            cout<<s1[i];
    }
    cout<<endl;
    return 0;
}