1. 程式人生 > >3652 B-number 數位DP(記憶化搜尋)

3652 B-number 數位DP(記憶化搜尋)

B-number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 9200    Accepted Submission(s): 5481  

Problem Description

A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input

Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output

Print each answer in a single line.

Sample Input

13 100 200 1000

Sample Output

1 1 2 2

題意:找出1到n中即含13而且能整除13的數字的個數。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
#include<map>
#include<set>
#include<cmath>
#include<cctype>
#include<ctime>
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
typedef long long ll;
typedef unsigned long long ull;

using namespace std;

int a[25];
ll dp[25][25][3];

ll dfs(int len,int modd,int cnt,bool limit)
{
	if(len==-1) return (cnt==2)&&(modd==0);
	if(!limit&&dp[len][modd][cnt]!=-1) return dp[len][modd][cnt];
	ll ans=0;
	int up=limit?a[len]:9;
	for(int i=0;i<=up;i++)
	{
		int mod=(modd*10+i)%13;
		int ccnt=cnt;
		if(cnt==0&&i==1) ccnt=1;
		else if(cnt==1&&i==3) ccnt=2;
		else if(cnt==1&&i!=1) ccnt=0;
		ans+=dfs(len-1,mod,ccnt,i==a[len]&&limit);
	}
	if(!limit) dp[len][modd][cnt]=ans;
	return ans;
}

ll fun(int x)
{
	int len=0;
	while(x)
	{
		a[len++]=x%10;
		x/=10;
	}
	return dfs(len-1,0,0,1);
}

int main()
{
    int n;
    while(cin>>n)
    {
    	memset(dp,-1,sizeof(dp));
    	cout<<fun(n)<<endl;
	}
    return 0;
}