HDU 1003 ( Max Sum )
Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 294795 Accepted Submission(s): 70011
Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
#include<iostream>
using namespace std;
int main()
{
int t,i,m=0,n,a[100001],s=0,num=-1001,x,y,j,z;
cin>>t;
for(i=1;i<=t;i++)
{
cin>>n;
for (j=0;j<n;j++)
{
cin>>a[j];
}
m=0;
for(j=0;j<n;j++)
{
s=s+a[j];
if(s>=0)
{
if(s>=num)
{
num=s;
x=m;
y=j;
}
}
else
{
if(s>num)
{
num=s;
x=m;
y=j;
}
m=j+1;
s=0;
}
}
cout<<"Case "<<i<<":"<<endl;
cout<<num<<' '<<x+1<<' '<<y+1<<endl;
if(i!=t)
cout<<endl;
num=-1001;
s=0;
x=0;
y=0;
}
}