1. 程式人生 > >zoj 3829 Known Notation (貪心)

zoj 3829 Known Notation (貪心)

Known Notation
Time Limit: 2 Seconds      Memory Limit: 65536 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input

3
1*1
11*234**
*

Sample Output

1
0
2
題意:判斷下列給出的表示式是不是RPN表示式。數字之間的空格已經省略了。有兩個操作,一個操作是可以在任意位置加入字元,另一個操作是可以將兩個任意位置的字元交換位置。問最少經過多少次操作可以把輸入字元變成RPN表示式。 思路: 數字字元有多少並不重要,關鍵是數字字元至少要比*字元多1個,而且數字字元應該儘量靠前排列,而*字元儘量靠後排列。
這樣我們首先應該考慮,插入的操作,當數字字元少的時候就一定要插入,不然不管怎麼交換都不能成為RPN表示式。所以當數字字元沒有達到*字元+1的個數時就要插入。
然後在考慮交換,交換時應該將靠前的數字字元與靠後的*字元交換位置。 程式碼:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        while(n--)
        {
            char a[1005];
            int num1=0,num2=0,exa,ans=0;
            scanf("%s",a);
            int len=strlen(a);
            for(int i=0;i<len;i++)
            {
                if(a[i]=='*')
                    num1++;
                else
                    num2++;
            }
            exa=num2-num1-1;//數字字元比*字元+1多的個數
            if(exa<0)
                ans=-exa;
            int pre=ans;//當前字元前面有多少個數字字元
            for(int i=0;i<len;i++)
            {
                if(a[i]=='*')
                {
                    if(pre>=2)
                        pre--;
                    else
                    {
                        int j=len-1;//從後往前找
                        while(j>=0)
                        {
                            if(a[j]!='*')
                            {
                                swap(a[i],a[j]);
                                ans++;
                                pre++;
                                break;
                            }
                            j--;
                        }
                    }
                }
                else
                {
                    pre++;
                }
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}