poj 2392 Space Elevator 排序(貪心)+多重揹包 仍然很水 ★★
阿新 • • 發佈:2019-01-27
Space Elevator
Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.
* Line 1: A single integer, K
* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.
From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.
Time Limit: 1000MS | Memory Limit: 65536K |
Total Submissions: 9955 | Accepted: 4731 |
Description
The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000).Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.
Input
* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.
Output
* Line 1: A single integer H, the maximum height of a tower that can be builtSample Input
3 7 40 3 5 23 8 2 52 6
Sample Output
48
Hint
OUTPUT DETAILS:From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.
Source
按照最大高度將物品從小到大排序,之後根據這個順序進行DP。
實際上還是有些東西值得思考的,我看了題目就感覺要升序排列。
這之中深層的原因是,對於我們分階段進行的動歸,前面的階段在前,後面的階段在後,也就是說
每次轉移,都是對這個狀態最後的某段在進行改變。
實際的物品排列應該是限制高度較小的在前面放,然後才是限制高度較高的在後放,
這其實是個貪心,也就是說這個題目是貪心+dp。
舉個例子,假如說先考慮,h = 4 ,limit 9,再考慮h =4 ,limit 5,則第一步從v=0~9,第二步0~5, 最終答案是h=4。
如果先考慮h =4 ,limit 5,再考慮h = 4 ,limit 9,則結果是9,
第一種順序是錯誤的,因為進行了這麼兩階段的動歸,實質上永遠是把物品1放在物品2下面去了,當然是不對的。
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<cctype>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI (4.0*atan(1.0))
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n) for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n) for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n) for(int i=(n) ;i>=0 ;i--)
#define lson ind<<1,le,mid
#define rson ind<<1|1,mid+1,ri
#define MID int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk make_pair
#define _f first
#define _s second
using namespace std;
//const int INF= ;
typedef long long ll;
//const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
const int INF =0x3f3f3f3f;
const int maxn= 400+20 ;
const int maxV= 40000+20 ;
int n,V;
struct BAG
{
int val;
int limit;
int num;
bool operator<(const BAG &y)const
{
return limit<y.limit;
}
} bag[ maxn];
bool dp[maxV];
int main()
{
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)
{
scanf("%d%d%d",&bag[i].val,&bag[i].limit,&bag[i].num);
}
memset(dp,0,sizeof dp);
dp[0]=1;
sort(bag+1,bag+1+n);
for(int i=1;i<=n;i++)
{
V=bag[i].limit;
int tot=bag[i].num;
for(int cnt=1;cnt<=tot ; tot-=cnt ,cnt*=2)
{
int cost=cnt*bag[i].val;
for(int v=V;v>=cost;v--)
{
dp[v]=dp[v-cost]|dp[v];
}
}
if(!tot) continue;
int cost=tot*bag[i].val;
for(int v=V;v>=cost;v--)
{
dp[v]=dp[v-cost]|dp[v];
}
}
for(int v=bag[n].limit;v>=0;v--)
{
if(!dp[v]) continue;
printf("%d\n",v);
break;
}
}
return 0;
}