1. 程式人生 > >poj1742 多重揹包的可行性問題

poj1742 多重揹包的可行性問題

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4
/**
poj 1742  多重揹包的可行性問題
題目大意:給定n種面值的硬幣面值分別為wi個數為ci,問用這些硬幣可以組成1~m之間的多少面值
解題思路:樓教主的男人八題之一,算是一個經典的問題,定義一個sum陣列。每次填dp[j]時直接由dp[j-weight[i]]推出,
          前提是sum[j-w[i]]<c[i].sum每填一行都要清零,sum[j]表示當前物品填充j大小的包需要至少使用多少個.複雜度O(n*m)
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <iostream>
using namespace std;

int n,m;
int w[105],c[105],sum[100005],dp[100005];

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&w[i]);
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&c[i]);
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        int ans=0;
        for(int i=0;i<n;i++)
        {
            memset(sum,0,sizeof(sum));
            for(int j=w[i];j<=m;j++)
            {
                if(!dp[j]&&dp[j-w[i]]&&sum[j-w[i]]<c[i])
                {
                    dp[j]=1;
                    sum[j]=sum[j-w[i]]+1;
                    ans++;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}