1. 程式人生 > >Ants(POJ No.1852) 腦筋急轉彎

Ants(POJ No.1852) 腦筋急轉彎

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7418 Accepted: 3426

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207
假設2只螞蟻相遇後,互相穿過對方
Problem: 1852		
Memory: 572K		Time: 125MS
Language: C++		Result: Accepted
Source Code

#include <cstdio>
#include <algorithm>
using namespace std; 
const int MAX = 1000000;
int L, n;
int k[MAX];

void Solve()
{
	int minT=0;
	for(int i=0; i < n; i++)
		minT = max(minT, min(k[i], L-k[i]));
	
	int maxT=0;	
	for(int i=0; i < n; i++)
		maxT = max(maxT, max(k[i], L-k[i]));
	
	printf("%d %d\n", minT, maxT);
}

int main()
{
	int nCase;
	scanf("%d", &nCase);
	while(nCase-- > 0)
	{
		scanf("%d%d", &L, &n);
		for(int i=0; i < n; i++)
			scanf("%d", &k[i]);
		Solve();
	}
	return 0;
}