1. 程式人生 > >【HDU3949】XOR——線性基

【HDU3949】XOR——線性基

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 2^3^4=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.

Input

First line of the input is a single integer T(T<=30), indicates there are T test cases.
For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,……KQ.

Output

For each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.

Sample Input

2
2
1 2
4
1 2 3 4
3
1 2 3
5
1 2 3 4 5

Sample Output

Case #1:
1
2
3
-1
Case #2:
0
1
2
3
-1

Hint

If you choose a single number, the result you get is the number you choose.
Using long long instead of int because of the result may exceed 2^31-1.

線性基裸題.線性基好像2014集訓隊論文有

#include <bits/stdc++.h>

using namespace std;

typedef long long LL;
const int maxn = 11000;

LL a[maxn];

int main() {
    int T,z = 1;
    scanf("%d",&T);
    while(T--) {
        int n;
        scanf("%d",&n);
        for(int i = 0;i<n;i++) {
            scanf("%lld",&a[i]);
        }
        int row  = 0;
        bool flag = false;
        for(int i = 62;i>=0&&row<n;i--) {
            int r  = row;
            for(int j = row+1;j<n;j++) {
                if((a[j]>>i)&1) r = j;
            }
            if((a[r]>>i)&1) {
                swap(a[row],a[r]);
                for(int j = 0;j<n;j++) {
                    if(j!=row && ((a[j]>>i)&1)) {
                        a[j] = a[j]^a[row];
                        if(!a[j]) flag = true;
                    }
                }
                row++;
            }
        }
        int q;
        LL k;
        scanf("%d",&q);
        LL ans ;
        printf("Case #%d:\n",z++);
        for(int i = 1;i<=q;i++) {
            scanf("%lld",&k);
            if(flag) k--;
            if(k>>row) {
                printf("-1\n");
                continue;
            }
            ans = 0;
            for(int j = 0;j<row;j++) {
                if((k>>j)&1) {
                    ans^=a[row-1-j];
                }
            }
            printf("%lld\n",ans);
        }
    }
    return 0;
}