1. 程式人生 > >hdu 1171(普通型母函式)

hdu 1171(普通型母函式)

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11501    Accepted Submission(s): 4026


Problem Description Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input 2 10 1 20 1 3 10 1 20 2 30 1 -1
Sample Output 20 10 40 40
Author lcy 題目型別:普通型母函式 題目描述:略 題目分析: 這題的結束條件看錯了,超時了好幾次。 程式碼如下:
#include <stdio.h>
#include <memory.h>
#define N 250001
#define M 51

int r[N];
int t[N];
int v[M];
int c[M];
int n;
int Max;

void init(){
    memset(r,0,sizeof(r));
    memset(t,0,sizeof(t));
    int i,j,k;
    int pmax = 0;
    for( i = 0; i <= v[0]*c[0]; i += v[0] ) {
        r[i] = 1;
    }
    pmax = v[0] * c[0];
    for(k = 1; k < n; k++) {
        for( i = 0; i <= pmax ; i++){
            for( j = 0; j <= v[k] * c[k]; j += v[k]) {
                if( r[i] != 0 && i + j < N) {
                    t[i+j] = 1;
                }
            }
        }
        pmax += v[k] * c[k];
        for( i = 0; i <= pmax; i++){
            r[i] = t[i];
            t[i] = 0;
        }
    }
    Max = pmax;
}
int result(){
    int pos = (Max % 2 ==0 ) ? Max/2 : Max/2 + 1;
    int i;
    for( i = pos; i <= Max; i++){
        if(r[i] == 1){
            return i;
        }
    }
    return -1;
}


int main()
{
    while(scanf("%d",&n),n > 0){
        int i;
        for( i = 0; i < n; i++){
            scanf("%d%d",v+i,c+i);
        }
        init();
        int a = result();
        printf("%d %d\n",a,Max-a);
    }

    return 0;
}