1. 程式人生 > >HDU 1028 (母函式或者dp)

HDU 1028 (母函式或者dp)

“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627

c1[]為係數 :係數則為方案數
c2[]為指數 :指數為組成的和
* 母函式解法*

#include <iostream>
#include <cstdio>
using namespace std;
const int  N=122;
int c1[N],c2[N];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<=n;i++)
            c1[i]=1,c2[i]=0;
        for(int i=2;i<=n;i++)
        {
            for
(int j=0;j<=n;j++) for(int k=0;j+k<=n;k+=i) //每次指數加 i c2[j+k]+=c1[j]; //j+k 為指數 c2[j+k] 為該指數項的係數 for(int j=0;j<=n;j++) c1[j]=c2[j],c2[j]=0; //將c2複製到c1,c2初始化為0,避免重複計算 } printf("%d\n",c1[n]); } }